Immediate crash on 3d dwg and dxf export everytime


#1

Hi there,

Everytime I try to export a 3D file to DWG or DXF sketch up immediately crashes.

I have simplified the model, and even turned off all extensions, and shut all other programs. But no luck.

All help and advice appreciated.

Many thanks,

David


#2

Can you share the file so we can see what you are dealing with?


#3

Thank you - here is a link to it: https://www.dropbox.com/s/z707xmifztgu98u/Flinders%20Street%20Sign%20position.skp?dl=0


#4

I tried exploding all the content but the same problem happens unfortunately.


#5

I didn’t have any issues exporting to dwg but I purged the model before doing so. Do you know how to purge models?

Flinders Street Sign position.dwg (2.7 MB)

I also exported the DXF file without issue after purging the model.


#6

Is that with this:
?


#7

Window > Model Info > Statistics > Purge Unused


#8

Thanks for doing that. I did try reimporting your DWG file into a blank sketchup file just to check it, but only one part of the model appears… Not the full content.


#9

Thanks for showing me the purge. That does let it export, but then the resulting file is incomplete… mine looks the same as the one you created… missing 2/3rds of the content. Very odd.


#10

i really appreciate your help by the way!


#11

Exporting it as a dwg creates a flat 2D image. What is your end goal? Why would you need to export the file as a dwg and open it in SketchUp?


#12

Great question. My goal is to provide a 3D file to an engineer who uses DWGs rather than Sketch Up. My only reason to reimport it is to check if it has been successful before I send it to him. You will see that the 3D file is made up of 2D plans and sections set out in space, and then one 3D component placed in the correct position in space. It is the setting out of that that I want to provide in 3D. Thanks again, David


#13

Thanks @ad_1011 for trying. All a bit frustrating not to be able to solve it. But appreciate your effort.


#14

It has something to do with the batman logo which you downloaded from the 3DWarehouse. I didn’t see the component in the model when I selected it via outliner and when I selected the rest of the model via outliner and pasted in place in a new file I could export it.
When I downloaded it from the 3dwarehouse it came in with a 2900KM span.


#15

Hi @MikeWayzovski thanks for trying that. Yes I remember that symbol being a nightmare!

I do not need that component in this export so it can be purged. I had thought it was!

I still haven’t been able to export it. Either it crashes or no file is made. Did you manage to make a DWG successfully with all the components (minus the batman sign)?

Thanks for your help.

David


#16

Ok I finally got it.

Open an new SU file and “Paste In Place” the plans, sections and component that you need. I Successfully exported a 3D dwg without any issue.


#17

…oh, I didn’t see this haha


#18

Man you guys are good for trying to help @MikeWayzovski and @ad_1011

It now doesn’t crash, but now if just whips through as if it has done it, but no new .dwg file is created… the folder remains empty - I double checked the file location incase!


#19

Hi there,

Did you resolve your issue? I’m having the exact same problem.


#20

Hi there.

I discovered that something - some elements of the drawing - was not resolving itself.

I ended up making 5mm spaces between some key elements until it finally worked. It drove me nuts.

Good luck!

David

David Hebblethwaite
Director - ART of FACT
+64 (0) 2102 062062
dmt.hebblethwaite@me.com