Sketchup Pro 2023 w/ Windows 11 - Crashing with Enscape

Sketchup has been crashing repeatedly while using Enscape - specifically while using Objects (placing lighting.) Any ideas here on how to mitigate this? It’s really putting a wrench in my workflow.

I use sketchup with enscape on windows 11, I haven’t had any issues with it, have you updated your gpu drivers?

I’ve checked them in Device Manager and it tells me I’m up to date. -Should I just go to the website and download most recent to be sure?

Yes! Don’t trust Windows to tell you that the graphics drivers are up to date.

When SketchUp crashes do you get Bug Splats? Have you been sending them in with something to identify they came from you? Email address and name?

Maybe there’s something with the SketchUp model file that is problematic. You could share the file so we could take a look at it and see if we can see something that might cause problems.

Does SketchUp crash if you try to do the same thing with a model containing a simple cube?

All good questions. I do get bug-splats but haven’t sent them in.

I’m downloading the updated Nvidia driver so we’ll see what that does. -Will try creating a simplified file to see if that makes a difference.

The file I’m working in was exported from a Revit model and is relatively large as it includes multiple structures. I will send it along if this doesn’t seem to fix the problem.

Thank you!

If you had been sending them in @colin could take a look at them to see what they point to.

Just happened again and sent the bug splat in. -Only seeing this now though so did not include @colin. My name and email address are included. Now I will try on a test file…

Share your model file, too.

It’s too big - will have to WeTransfer if that’s ok. Can you provide an email address?

That’s fine. Just share the link here.

Will do. FYI - was just experimenting w/ a simple box and after placing three lights in Enscape Objects - the file froze…Did not fully crash but I can’t use my mouse to click on anything.

I’m not sure what’s going on in your test model but I expect the size of this one isn’t helping.

I fixed incorrect tag usage.
Screenshot - 6_11_2023 , 4_23_06 PM
And purged unused stuff from the model. You seem to be hoarding components and materials that you don’t need.
Screenshot - 6_11_2023 , 4_26_42 PM
Of the remaining materials some of them are quite large and there are many that are duplicated. That stuff could be cleaned up to improve the efficiency in your model.

I would also suggest you look at face orientation in your model. The exposed blue back faces might be problematic in your renders.

The cleanup I did reduced the file size by 68%. Maybe this one will perform better for you.Here’s the link. You should still clean it up further but hopefully it won’t tax your computer so much.

Wow! Thank you so much!

You’re welcome. Did the model behave better for you?

Sorry for the delay. The file was definitely easier to work in and I appreciate your work - which I’ve been continuing to refine. But this morning, while placing lights w/ Enscape Object, it crashed again. It’s such a consistent occurrence. Today I didn’t even have the Enscape App open - so it wasn’t having to render the lighting changes as I was placing them. And it still crashed.

Ah - just got a notification there’s an Enscape update…perhaps this will rectify the problem. Stay tuned.

Worked for awhile and just crashed again under the same circumstances - placing lights. I think it’s an Enscape bug.

Try disabling RTX shadows in the enscape settings

I also use enscape and I don’t have that bug, recently I made a render of a project where I placed a lot of lights and sketchup never crashed.