Sketchup Pro 2022 - Page size not showing for any printers and no scaling available

I am using Pro 2022 on Win 11 and when I tried to print to scale, the scale boxes and drop downs are empty and then I also noticed that the page size is empty. I am using a printer with standard letter size and I tried switching to the Microsoft PDF printer, same thing…no entries for page size or scale. I am using parallel projection and a standard Top view. Any suggestions?
I am using the HP Office Jet Pro 9010 printer with updated drivers

This seems to happen for some users and has been traced to print driver issues. Try this, though.

Open Print Preview.
Press OK.
Close the preview.
Open Print Preview again.

Are the fields populated so you can make the settings?

Out of curiosity, why not use LayOut? Setting up for scaled output is easier, the output will look better, and if you need a paper size larger than your printer will handle you can set that in Document Setup and send the exported PDF to a service with a larger printer.

No luck. The reason I am trying to print directly from Sketchup is that I am teaching a class on a different topic but will be using sketchup to make and print to scale a simple drawing of the project. The class does not know sketchup and I wanted to keep it as simple as possible so the native print to scale would jave kept it that way.

I wonder why the print to pdf is not working?

I guess I don’t know why it’s not working for you.

What happens if you choose the XPS printer option and OK the preview. Then close and open the Print Preview panel again and change to Print to PDF?

By the way, what sorts of things are you modeling and printing to scale?

When I selected the XPS and went to Preview, it showed values in the boxes as it should. Switched to Microsoft Print to PDF and to my 9010 HP and the boxes are empty again. Seems like it is associated with specific drivers (also as you suggested). I did print them fine through Layout and all worked well on pdf and 9010 HP so Sketchup is part of the problem.
I am printing some 2D drawings that the wood working students will adhere to their wood and use to mark all the hole locations

1 Like

I wonder if uninstalling the 9010 HP and reinstalling will help

I don’t know if uninstalling the 9010 will do anything or not. Is it using the Windows-supplied version of the drivers or the HP-supplied version?

I get keeping it simple for the students but it might still be a good idea to go through LayOut. If they render the viewports as Vector they’ll get cleaner line work than they’d get direct from SU. Maybe it doesn’t matter but maybe it would help.

Not sure how to tell. I know when I installed the priter (on my home network) a few years ago, I used HPs driver package so it is probably still in place. I checked the HP printer utility and it says I have the latest drivers

I would suppose so.

Did you just check on your computer or did you go to the HP site to see what their latest driver version is?

I used the “HP Smart” utility and asked it to update the driver and it came back and said it was the latest (the date on the driver was a few months ago)

Do you think the website will offer something different?

It might. Wouldn’t hurt to check.

OK thanks

1 Like

I just downloaded the latest driver and it reported that I was already up to date.
I am actually more bothered by the fact that the Microsoft PDF printer isn’t working correctkly in sketchup. It works great in all other apps

I guess I haven’t used the Microsoft PDF printer for years. It did work for me when I was testing what I suggested to you earlier.