SketchUp Pro 2021 "save as" previous version issue

Hi! After updating to 2021 version I see that save as shows the pop-up menu as shown in the screenshot.

What is more, is that the saved file extension I’m getting looks like “.skp)”, with bracket from the right. If I choose save as 2021 or 2020 that works fine. Of course, I can rename it manually but I’d like to find a solution for it. I’ve added an empty scene to attachments, don’t know if this will be helpful.
empty scene.zip (7.3 КБ)

BTW the installation of SU Pro 2021 has been run as administrator.

1 Like

Is there any reply going to be?)

Hello,

type run in windows menu, then regedit and hit F3. Look for .skp) and tell me if it returns a result in any other location than explorer/fileexts ?

Hi, Paul! Here is what I’ve got

And this is with bracket

you forgot the bracket :slight_smile: you should get two results for sure because at some point windows encountered the .skp) extension in the explorer, but I wanted to know if you had any others.
hit F3 again to look for next

Also, it finds it in “recent docs” and that’s all except “explorer/fileexts”.

:confused: did you try many times reinstalling as admin ? you may want to try reinstalling/repairing microsoft visual C++ as well.

Otherwise can you try installing this extension Extension | SketchUp Extension Warehouse ?
it says it is not compatible with 2021 sketchup but it should be.
once installed, pick file > save in legacy format and see if it is any different ? (I don’t think it will, but it’s worth a try)

  1. Tried to repair it as administrator. 2. Tried to reinstall visual c++. 3. Tried to install Eneroth Legacy Save. No success :wink:

I don’t know then. I would do a clean reinstall - uninstalling sketchup 2021, c++ redistributable, and .net Framework and reinstall everything again, and perhaps run sfc /scannow in a cmd window to check for windows file errors too, but it’s a weird bug you have there !

@colin Hi! What can be a reason for that?

thanks!

1 Like

I’m suspecting a localization issue, but don’t really know. What happens if you install SU in anotehr language?

@colin, could you follow up on this?

I thought of it, but the problem is that open and save dialogs in sketchup are windows language dependants…

Honestly, I wouldn’t like right now to reinstall it choosing another language because of I remember once I did it for some reason (I mean I installed EN version on RU) and after that the UI came crazy showing something with RU and something with EN )). Of course that’s not a big problem but anyway.

And I should say that this is the first time I see such a problem with “save as” function. I start using SU when the first 2019 version has been released and I was always using RU language and there were no any problems with it.

I have asked the appropriate team members to pop by to look at the issue.

1 Like

I have absolutely the same problem, my version of program 21.0.391.

1 Like

I have absolutely the same problem!!!