SU Pro 2021 : right-click save as (component) not working

Hello all.
In SU Pro 2021, I can’t right-click ‘save as’ (a component) more than once.
I keep using this function to iteratively update my model in Lumion but I realized that the component skp wasn’t saved after a while.
If I shutdown SU and reload the model in a new session, it allows one save as again but that’s it. Then after one save, it begins to bug again.
The workaround is to ‘save as’ in earlier versions of skp, like 2018 for example.

I hope this will be fixed in future versions.

Are you giving the component a new name each time?

Out of curiosity, did you install SketchUp correctly by right clicking on the downloaded installer and choosing Run as administrator?

BTW, your profile says you are still using SU2017. Maybe you could update it?

Hello Dave,

No, the principle is that I keep overwriting the skp because Lumion has a routine to reload the updated skp file (to keep the materials and the mesh position). Usually, SU warns for overwriting and I agree.

I tried to ‘save as’ the component to another folder, just to check if the target skp file wasn’t flagged as ‘read-only’ mode but I only got a weird Flextools warning popup:
Error occured: No such file or directory @ realpath_rec -

It could be a #Flextools error?

Thanks, I updated my profile :smiley:

I see.

What about the correct installation?

I have an admin account so I rarely use the right-click ‘run as admin’ command but next time there’s an update, I’ll use it. :wink:

It could, or some other plugin. I have seen it discussed in these forums, but I don’t remember what the actual culprit was. Check that your plugins are up to date.

It’s not the same. Either way, you should go ahead and find the installer, use Run as administrator and then choose Repair.

I’ll do.
I understand the principle but I never used it to install SU (sometimes for some very demanding softwares that use physical dongles for example) until now and I never got any issue with that. :wink:

I have been pushing my luck since version 3 of SketchUp and never used the right-click ritual. No problems that could be attributed to that. As it is wholly undocumented, I guess that it must be due to some specific non-Microsoft, non-Symantec or non-F-secure antivirus/firewall application. It seems that on some setups, the installer is unable to set up the necessary folder paths without the procedure. Something, then, is preventing the installer from creating the necessary files and folders. Also, in a corporate environment file permissions might be set up in a more convoluted way than at home.

There are plenty of examples throughout this forum and other places where failure to use Run as administrator resulted in problems mostly related to file permissions. Some people manage to avoid them but we’ve seen lots of cases where repairing the installation using Run as administrator has fixed things. No matter what, it won’t hurt to do the repair.

It could also not be a SU issue to begin with.
It only happens when I use SU with Lumion Pro 11 and this iterative update workflow.
I reinstalled SU2021 using the ‘Run as admin’ routine and if this happens again, my next culprit could be the Lumion build.

1 Like

Hi @DaveR

Hope you are well.

To digress slightly in this, I’m assuming the update within 2021 to the latest version works ok, as the update and installation is done from within Sketchup? As in, it notified me of a newer version, I selected yes to Download and Install, which it then did.

Mike

Hi Mike!

Yes. Doing as well as can be expected. And you?

The update does seem to work fine for me. If there’s doubt, one can still do it the old fashioned way, though.

Yes, ok thank you.

It seems to have worked ok for me and installed everything ok, keeping everything in the right place.

Was just worried that it’s different from the ‘Run as Administrator’ way.

Mike

1 Like

Hello all.
I’ve got a reply from Yoni, the Flextools developper:

"You’ve encountered a Sketchup bug that was introduced with Sketchup 2021. Basically the Right Click > Save As command (and same with saving in ComponentFinder) doesn’t work when saving for a second time. When FlexTools is not installed, the save as fails silently… (be careful) and when FlexTools is installed at least you get an error message.

The bug was reported and acknowledged by Sketchup about a month ago but they haven’t fixed it yet. I have just sent a message to them asking what’s up with this, because it is quite a serious bug - and I cannot recommend 2021 to anyone.

For now, I recommend to stick with Sketchup 2020 and email Sketchup to bug them about this too… On the forums would be good too. Maybe they will wake up.

Really sorry about this. I hope 2021 (Sketchup and the world) will be better. "

That’s it, folks.
So I 'll report it to Trimble to add some weight in the protest :smiley:

Can you confirm which version of SketchUp you are on? What you’re describing sounds a lot like one of the things fixed in the update from nine days ago:

“Fixed an issue where a component could not be saved and then saved again with a different name.”

I updated to 21.0.391 64bit yesterday.
I still have the ‘save as’ bug.
However, now I can delete the target file (or move it in another folder) and resave the compo skp with the same name. Yesterday (with the previous SU build) , I wasn’t even able to save the compo more than once. The only workaround was to save as a 2018 skp.
I can also save the compo in another folder (like the desktop) but I can’t overwrite, it seems.
Strange…

BTW I don’t have thumbnails in Windows 10 with 2021 skp. But I have them if I save as 2018 skp…

Ik having the same issue with the thumbnails… how can that be?

It still isn’t solved.
I can’t save as 2021skp. I have to save as a previous version and then it works.

So this doesn’t work for you?