I saved my file under a new name, and now my components aren't there

The title says it all. It has basically the same name, only added “-02”
I have done some significant work on this, saving every so often, and am only now finding out that my components aren’t here! If I go back to the previous file, my new work will be missing. I have checked online about this, and went to C:, ProgramFiles, SketchUp 2021, and saw no components anywhere, not in any folder. Checked here under “Your topic is similar to…” but none seem exactly on point. Can anyone help?

Just looked back at 1:27 AM on May 11 (orig posted 5 hrs earlier), and there have been 27 views, and nobody has any idea what has happened here? This is not only very disturbing, but will ham-string my work terribly! I made things like moldings that I need to use on more doors, and other things like that! The project should be finished by tomorrow, but I won’t be able to, without my components… Is this something everyone knows not to do – save your work under a new name? Any reply would be welcome!

Your question is an odd one and your setup is unclear.
Your profile says you are using the free web version, but then it also says 2020, 2017 and so on
and you have posted in the Pro section of the forum.

So if it is the web version it is possible that you have signed in with the wrong email.
If it is one of the other versions perhaps you aren’t looking in the inmodel section of the model.
Many many questions.
Saving as a new name shouldn’t change anything except the name, so it is unclear what you have done.
First thing would be to clear up any confusion by correcting your profile then attach your model for us to look at.
That should give us a starting point to work from.

Okay, thanks for telling me something! Appreciated muchly! I signed on with the forum when I was using the free version of 2017, but I’ve contemplated getting the pro version for a while, and currently am in the trial period of SU Pro 2021. So my profile may be a bit confusing, but it’s accurate. I plan on buying the license or whatever the annual subscription is now called, as soon as they nudge me to do it.

I came here to share my happy news – I remade that molding and turned it into a component, and BINGO! Hallelujah! My components all showed up!!! I don’t like the web version – I tried it out some months ago and couldn’t stand it! Everything that had been easy was a PITA, having to fumble around looking for one’s buttons. Making it look more “minimal” and “streamlined” may be trendy in the home fashion world, but making us click twice after being used to clicking only once, is only going to create animosity toward Trimble! I will NEVER use a web-based version. Thank the universe that I’m old – What I have on my computer will serve until I’m gone, I’m sure.

Anyway, Box, my profile is correct as is. Sorry it confused you, but I don’t know my way around here very well, and simply added what is true now. I still have 2017 on the computer, so that’s actually still true, also. Meanwhile, I will now more happily and faster be able to finish this project, and thereafter embark on some kind of organized training so that I can avoid some of the problems I’ve gotten myself into. Thank you so much for replying – I had really wondered what people were thinking, if they came and left without saying a word…

Thanks again!

I’m not trying to be pedantic, just pointing this is the part that causes confusion.
This is telling me that you have selected a web version and so my answers should be relevant to that version.

But is seems your problem is solved for now.

No, that’s not pedantic. You are totally right. My oversight – that was back from when I briefly had the web version to try it out, and totally forgot I had given it here as what I’m working with. Sorry to be the source of the confusion, and I will correct that ASAP. Well, maybe I should wait until I’ve actually paid for my 2021 Pro… because otherwise, it’s free 2017, but not for long… No, I need to clear this up now, lest it confuse anyone else!
Thank you for your patience with me, Box, and indeed, for talking to me at all!

I’ve gone into my profile, and see no way to change the license type, or anything else next to my pic (which I CAN change!), I’m sure other people have upgraded… so how do I do this? -G

If you go to this page:

do you then see a Preferences option to the right of the page? If you do, click on that, and then click on Profile in the list on the left of the page. You should be able to change license type, and system information.

Thank you for answering, and helping me out again. Don’t know if the universe has it in for me! Th

e Preferences show up under the Person-icon on the right. When I click it, the items on the left don’t include Profile. I checked under the three bars, I’ve hovered over everything else…

Hope I can attach the screenshot of what I see.

I shall try the second “Preferences,” next!

Found it! Made the change, and added my region. Thank you so much for your help!


In case you don’t know about this, that green 2 number means that you have two private messages that you haven’t yet read. Click on the 2 to see what someone has sent you.

Thank you, Colin, you were right: I didn’t know!

I had clicked on the number over my head, and a drop-down window had opened showing me a lot of messages. I thought that when I read those, I had seen all there was! Only after seeing your post here did I go back, and saw that just reading what turned out to be a summary, or teaser, of the actual message, and noting that the numbers still didn’t change, did I go back and try something new – click on the message-teaser itself. And THAT took me to the whole message! I have to say, it’s not exactly intuitive… but with a lot of prodding from all the knowledgeable people here, I am finding my way!

I am very glad you spoke up! It would have taken a lot longer for someone else to take pity on me, I’m sure! Thanks, Colin!