Sketchup Pro 2021 - I notice a delay in deleting geometry

Hi - there I have notice that deleting geometry in version 2021 seems to be responding slower then in 2020. This might be a very strange and unique issue.

2020 seemed to respond quicker to deleting geometry. Normally a large file takes longer to respond especially imported CAD 3D data. This is I understand and have experienced. But this happens when there is not heavy geometry at all.

Also when creating groups there is a delay. Again this is not heavy geometry. For example I applied this to a object with 142 entities.

Does anybody experience this too. If not then I know it might be on my side.

I’m currently working on a new workstation i9 1900K CPU 3.7Ghz, RTX 3080, 64 GB ram, Windows 10.

Thank you.

I haven’t noticed what you described on my setup…

I’d be checking the graphic driver is up to date, being new doesn’t mean it is up to date, and check at Nvidia don’t let windows tell you it is.
Also look at the Fast feedback and Antialias setting in Window/Preferences/Opengl

Thank you for your replies. I did check that fast feedback. Should be off- right? Mine was on.

Please see below example again. Took 1 min to delete this. Wanted to upload clip was to large so i took snapshots.

How to you ensure that Windows do not control the updates to Nvidia?

I just feel like 2020 was a bit more snappy with the delete command :wink: in my experience.

Updating (using a Clean install and a NVidia Studio driver) is a good idea.

I’ve had similar issues to this when things have been running in the background…processes such as virus scanning or other software updates.

Can you check your system resource monitor for activity (cpu)? You may find something else is eating up your system capacity.

Does this happen on all models or just the one? Does the same thing happen if you import your SKP model or geometry into a new file, or cut & paste the geometry into a new (blank) model?

Generally, sometimes a model may not be large, but can be slowed down a lot if you have a lot of tags, scenes and styles, and - especially - if you have a lot of nested groups an compoents (lots of layers deep…such as you may find if you import things from other CAD/modelling software). The slow creation of groups can sometimes be put down to this.

Very high res textures in your model could also be to blame (potentially using up GPU memory)

And then there are extensions…is it quick for you to temporarily disable some of the more complicated ones that you may be using?

Basically, with Nvidia cards “Fast feedback” ought to be On, and Off with integrated graphics. Check that SketchUp is using Nvidia.

I would also try disabling v-ray.

Hi there.
I have noticed the same issue on my SETUP.
"Motherboard: ASROCK X399 Taichi;
CPU: AMD Ryzen Threadripper 2950X 16-Core;
RAM: G.Skill RipjawsV DDR4 64GB 3200;
GPU: ASUS RTX 2080S Turbo 8GB;
SSD (M2): 1 - Samsung 970 EVO Plus 500GB
2 - Samsung 970 EVO Plus 1TB;
HDD: Seagate 3TB 7200rpm
PSU: Raidmax Cobra 1200W Gold;

I was reinstalling (clean install) windows 10Pro a few days ago.
Now I have everything up to date (drivers, softwares, etc.), but the delay in deleting is still an issue.

I’ve tried with SU21 without any Plug-Ins/Extensions, but still…
Maybe the coding of SU21 having some problems, and will be fixed in the future versions.

I’ve done everything what @AK_SAM suggested but nothing helped.

I could not manage to resolve it too.

The issue appears If there are two or more complex models in the scene.
I tried to separate some parts to an empty SU, but after a while the “delay” comes back.
Even Grouping takes way more time then in the previous versions of SU.
It’s really annoying when I want to group a… let’s say, a pillow, and it takes 10-15 mins.

I have noticed an alert in Vrays (Next V5) Progress Window, that my CUDA driver is newer what V-Ray supports.

Maybe downgrading the nVidia driver can be a solution to a supported version.

But downgrade for Me is no option, because too many other apps needs up to date drivers.

So for Me, is just waiting till a newer version fix this bug.

SAD

Have you tried disabling vray

Yes, I was making some tests on a clean SU setup without any plug in or extension.

I still think that it has some connection with the newer nVidia Studio Driver.

But as I mentioned above, there are too many apps what are requireing the new studio driver.
That’s why I do not want to do a downgrade.