Sketchup Pro 2019 slow modeling performance

Can anyone please help with getting pro-2019 to perform faster?

Since I’ve updated to the recent pro-2019 version, my models have become impossible to navigate and edit. I’ve tried small size files (7MB) and large files (700MB) but SketchUp is crashing my entire computer every time. I have had my task manager checked and the CPU is running at around 35 - 55%

My models are geo-located and I am trying to drape contour lines over the google topographical layout.
I have spent hours just trying to apply this one function and the models crash at around 40% progress.

With the larger models, I have tried turning layers off but even on this simple action the models crash.
What is up with SketchUp lately? these updates cost money (annual subscription) and then they cost money again (spending valuable hours trying to use this software)


what extensions do you have installed?

a few [ commercial ones ] aren’t yet compatible…


Fairly common ones, Meedek truss mainly. All other extensions are disabled.

1 Like

post your machine specs, 35-55% usage is quite high for modern machines, since SU is a single-thread application

I haven’t noticed any specific issues with my extensions running in 2019 (version 1 or 2). One thing you will want to make sure of though is turning off the Outliner while using any of the extensions. The extensions typically label each group/component so having the Outliner open will significantly slow down SketchUp while generating the geometry.

Thanks. I’ll check if turning the outliner off helps speeding up the process. Will post a feedback if I see a change.

1 Like