Sketchup Pro 2019 - Failed to read RBE/RBS file - Domain vs Local users

Hi.
I saw many threads with a same problem, but no solution. We use Windows 10 21H1, 16GB, GTX 1050 Ti and i7-10700.

In my tests I found that this problem occur only in domain users. Domain Admins and domain users with admin properties do not load the Sketchup plugins. But in local users, Sketchup works fine.

Windows 7 works fine, too (domain and local accounts).

I cant zoom in enough to read the actual message but those are typically error messages regarding extensions that are having issues. If you copy the text to text editor, you can look at each line and see what *.rbz file is having problems.

Sorry. I edited Image.
Seem that this problema do not have a solution.

When SketchUp is installed in Windows you must use the option to ‘Run as administrator’…

Whilst logged into Windows as the usual user [it does not matter if that user has some admin powers…],
find the SketchUp Installer’s exe file - usually in the Downloads folder,
right-click context-menu > ‘Run as administrator’…
Because it’s already installed choose the ‘Repair’ option when prompted.

This will ensure that all installed folders/files have suitable permissions…

Retry SketchUp…

Running the installer’s exe in any other way can result in strange permissions issues.
e.g. don’t double-click the exe to Run it… even as an admin it is subtly different…
You should not normally launch SketchUp as an admin, although a normal-user with admin powers is different, doing so leads to other unexpected issues - e.g. drag-n-drop into a SketchUp window opened that way will fail because Windows-Explorer runs at a base level of permissions, but you have elevated SketchUp’s permissions higher, and a lower permission-level can interact with higher level !

@TIG thanks. I will to try.

I installed 2022 Trial but occurs same error.

Somebody who had this problem recently found that with a user name of ‘administrator’ they saw the problem, but with a different user name they didn’t. I am wondering if any user name that starts with ‘a’ may have the problem? Stranger things have happened!

I will try some tests. Meanwhile, if you can easily try it, see if a different user name on the same machine has the same problem.

@TIG I did ‘Run as administrator’… and “Repair” option, but error persists.
I’m using a domain admin.
Local admin works fine.

1 Like

@colin Hi

My tests:

local account: Account-test (OK)
local account: test (OK)
local default administrator: (OK)

domain admin: admintest (Plugin Error)
domain account: 4016… (Plugin Error)
domain account: labtest (Plugin Error)

All of domain accounts show same problem.
All of local accounts works fine.

An important report: Windows 7 is working fine both local and domain accounts.

If you would be willing to save me some time with Google, how can I easily change myself to be a domain admin?

You need to have an DC. I don’t know other way.

You could tell me what a DC is! A lot of the advice I find online is for older versions of Windows, and I’m testing on Windows 11. Where would I go in Windows 11 to change myself from being a local admin to being a domain admin?

I know more about SketchUp than I do about Windows IT.

DC = Domain Controller.
It’s used in big companies to integrate many stations to a main server

You can to connect on my station

I believe your testing results. I want to make myself be a domain admin so that I can reproduce the problem.

On my work PC, which is Windows 10, I do log in with a domain log in, and I am admin, but I don’t see the problem there.

I will check with James, he knows more about this stuff than I do, and he has his own PC he can test on.

1 Like