Sketchup Pro 2018 Works Fine on External Display, but Freezes on Laptop Screen


#1

Sketchup Pro 2018
Lenovo Yoga 720 15"
Windows 10 Pro
i7-7700HQ 2.80mhz
16gb ram
Nvidia GeForce GTX 1050

Running SU with an external display on my laptop works fine (USB-C Hub with HDMI adapter) however running it on the laptop screen directly will not work. It loads either my current model, or even a blank template, and it just freezes.

This PC is less than a month old.

The laptop has a UHD 4k display which is a bit frustrating as many programs do not support the resolution yet, so I have the display resolution lowered to 1920x1080, however I’ve tried switching it back with the same results.

Also this laptop has two graphics cards, the GeForce as well as an on-board Intel HD 630. I have attempted to change which graphics card runs Sketchup, but still the problem persists regardless of choice made ( EDIT- When attempting to run with the integrated graphics, Sketchup crashes immediately and wants to send the report to Trimble). I suppose the really frustrating part of this is that it works fine when I have a second monitor attached, but not standalone.

Any thoughts? This is probably more of a Lenovo issue, but I haven’t had any other software behave like this, so I figured I’d mention this here.


#2

It might be an issue with your computer or the way you are connecting it. First I would go through all the power management options. Also make sure that your graphics drivers are up to date (in a new laptop the Nvidia drivers usually date from when the laptop model was introduced)

Is your laptop connected to the hub when SU freezes? Are you running on the battery when SU freezes? Do you close the laptop lid when you use the external monitor? Is the external monitor also an UHD 4K one?

The standard power management options in Windows might switch the Nvidia graphics off when you disconnect it from mains power.

Just thoughts


#3

All good thoughts.

First I would go through all the power management options. - All PM options are the same for power and battery.
Also make sure that your graphics drivers are up to date (in a new laptop the Nvidia drivers usually date from when the laptop model was introduced) - Updated all drivers.

Is your laptop connected to the hub when SU freezes? - No. When I’m using the hub (external monitor) all is well. When I am trying to use the laptop as it was originally intended, is when the problem presents itself.

Are you running on the battery when SU freezes? - Freezes in both scenarios.

Do you close the laptop lid when you use the external monitor? - No, I use the laptop screen as a second monitor (extended display)
Is the external monitor also an UHD 4K one? No, standard HD.

The standard power management options in Windows might switch the Nvidia graphics off when you disconnect it from mains power. - I hadn’t thought of this, but just attmepted in both power and battery modes and the situation is identical.

Just thoughts - Please keep them coming. I’ve exhausted my thoughts on this.


#4

What exactly happens when you say it freezes?
Does it happen on opening without any input from you or does it happen when you try to do something?
Does it work correctly on you laptop screen when you have the external display connected?
When it is working does it start up with a screen than needs input from you?
How do you disconnect the external screen, simply unplug or do you use the graphic option to remove the external display?


#5

What exactly happens when you say it freezes? ** - SketchUp fully loads with the black selection arrow on the mouse pointer. Once I attempt to use it or any other tool, typically I’ve tried with the middle mouse button press (orbit tool) and it locks up and doesn’t respond any more. **

Does it happen on opening without any input from you or does it happen when you try to do something?** -No, not until I attempt to use a tool. **

Does it work correctly on you laptop screen when you have the external display connected? **-Never tried this and my external monitor is at the office so can’t try until Tuesday. **

When it is working does it start up with a screen than needs input from you? ** -No, standard opening screen whether it be a blank template or an existing model. **

How do you disconnect the external screen, simply unplug or do you use the graphic option to remove the external display? ** -Typically I shut the computer off and then disconnect the cable when it’s already powered down. **


#6

Try this.
Open SU, once it appears to be open fully, hit alt + space bar, does a context menu appear on screen?, if not hit m, then any arrow key and then move the mouse around (without clicking) and see if anything appears on your screen with the cursor.


#7

Ok, opened SU and followed the instructions. Alt+space opened the context menu. Closed the menu and hit m. Move tool appeared with no issues or lag. Can move the cursor just fine as the move tool, however once I attempt to activate it, the system locks again. CPU draw for SU is over 25-30% in task manager and SU is not responding and then it closes out. Same as with the orbit or any other tool.


#8

It’s not what I thought it might be, that a dialog was opening off screen. Sorry.


#9

Have you tried the Nvidia setting that lets the application automatically decide which graphics card to use?

Charlie


#10

Sadly, yes. I’m tried all three options. Open using Nvidia, Intel, or auto decide (which is the Nvidia). Same issue with all three.


#11

I had similar issue w/dual graphics Precision laptop and manual selection of graphics card …after selecting let application decide resolved it for me…hoped that would work for you.

EDIT:
Have you also tried lowering your anti aliasing settings inside Sketchup? (Starting with lowest setting available)

Charlie


#12

Does it work correctly on you laptop screen when you have the external display connected?

Ok, got a chance to try this. I can run Sketchup just fine on EITHER monitor when I have the external monitor plugged in. So with the external monitor attached, I can run SU on both the external display as well as the built in laptop monitor. I can even carry the open window across both screens actively and use it wherever it lands.

So this issue is strictly isolated to the laptop monitor when the external is not connected. There must be some setting that changes when the external is attached, that is not set for standard use.


#13

Are you using Nvidia’s Nview or simply the Windows standard settings to arrange your monitors? At some time in the past, the former was incompatible with OpenGL, but I haven’t tested it for years, as the standard desktop settings are quite enough for my needs. Why it should affect you only in single display mode eludes me.

Another thought: The laptop screen in a Yoga is a touchscreen. I have never yet used one but it makes me wonder if that has something to do with this.


#14

My SU Pro 2018 simply does not work with external display at all. When I unplug external display it starts running fine.


#15

How are you connecting your external display? I have met this problem with some USB laptop docks. What if you close your laptop lid after connecting your external monitor? It might be that your Intel graphics only support OpenGL on one screen.


#16

Hey!

I have been experiencing the same problems.

To just clarify a few things - SU is almost completely unresponsive with one of the bigger models I am working on, which is extremely frustrating as I’m sure you know!

Did you have the lag issue with smaller files too or only big files?

This is such a shame as I have only just bought this laptop for this particular reason!

Have you found a solution yet? Do you recommend I use an external screen like you are?

Thanks a lot!! Any advice will be so helpful as this is really really slowing my work down.


#17

Sadly I did not find a proper resolution. All I can tell you is that every solution I tried individually, did not work. The only way I was able to get it functional again was to reinstall from the beginning. Not just Sketchup, but Windows and my whole laptop. I used the ‘Fresh Start’ option in Windows to start everything over from scratch. After doing this and reinstalling everything, Sketchup worked as intended.

If you do this, make sure to install sketchup as administrator and will also need to install the selection tool patch again that can be found on top of the forum.

I wish I had found the actual problem as wiping the pc is not a wonderful solution, but it was the only one I found.

Good luck.


#18

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.