Sketchup Pro 2018 Imports CAD drawing as a single line


I found a previous topic on this but it was automatically closed. I have imported CAD drawings more times than I can recall over the last several years. I know how to prepare and simplify CAD drawings for better import. I deleted all objects outside a rectangle in the drawing. I moved this CAD drawing closer to the 0 origin rather than it’s real-world coordinates.

However, it is importing as a single line. I’ve saved it as a 2010, 2004, and now 2007 version of dwg. I am using AutoCAD 2019, and my Sketchup version is Sketchup Pro 2018. Attached is a 2007 version of the AutoCAD drawing.

I would appreciate anyone’s help, and I’ll keep on trying on my end.

Sweetwater_50Perc_Hardscape_v2007.dwg (278.7 KB)


Ok, my own efforts have paid off.

I did some additional “explodes” of linework on one of the key AutoCAD layers. It removed some hidden hatch boundaries that may have created this strange issue.

It has been resolved.


1 Like

I was just going to post to say that I got it to work in 2018 and 2019. Explode everything. Then make sure to purge and audit. If that doesn’t work you can select all or certain layers and then WBlock them to a new clean file. FYI SU is working on a CAD to SU and back learning track for their new SketchUp Campus.…so keep an eye out for that in the coming months.

1 Like

Hi Eric,
Thank you for your response.

Perhaps you can help me with another issue after import. My curves are becoming too simplified upon import. I don’t have any splines. Please see the two attached images, and I’ve re-attached a new version of the AutoCAD file (2007).Sweetwater_50Perc_Hardscape_v2007.dwg (389.6 KB)

It’s also creating breaks where there was none before. Perhaps I need to repost to a new subject.

Example of a break caused after import. There are many of these.

I noticed that but didn’t want to assume you wanted additional help there :wink: I’ll follow up in a bit later today when I have a moment with some tips that should help a bit. Though not 100% as that’s the difference between CAD and SU…that the lines segment when converted.

For now…to keep you going, try adjusting the number of segments manually in ‘Entity Info’. Smaller arcs aren’t a problem but really long ones like these can be. Hopefully not too time-consuming to fix.

Thank you Eric. I’m finding I needed to get rid of a bunch of overlapping lines and flatten the file some more in AutoCAD anyway (I didn’t cause these!).

That’s great that I can change the number of vertices after it’s imported, thank you for the above tip!

No problem. I use Eneroth Flatten to Plane to flatten after importing. I have a few other techniques for reducing those overlapping lines so reach out again if you have any other trouble.

See if this helps you and it’s what you want: Sweetwater_50Perc_Hardscape_v2007.skp (1.7 MB)

Hi again, Eric. I’m not having so much luck with this solution.

All my line segments are separate lines. I can’t get that Segments space to appear under Entity Info.

Thank you, the lines are beautifully smooth. May I ask what you did?

However, I’m trying to create faces and it’s not working too well.

I used the Eneroth Flatten to Plane but it’s still not creating faces very easily.

I use pCon.planner for import.
Due to the specificity of the SketchUp (arcs, circles by segments), some problems occur in the import process, and some lines do not close as they should.
You can highlight and fix them using the Edge Tools plugin. For flatten to plane I used Fredo6 - FredoScale plugin.

Thank you,

Can you point me to where I can get pCon.planner?

Right before you replied, I found the ‘s4u Import DXF’ utility, but it costs $25.


I do not want to abuse the SketchUp hosts’ goodwill by putting a direct link, so I suggest you use Google search.

Hi @chriss Just an FYI that while @mihai.s pointed out some great tips once in SU, there is a bit more you may want to consider doing in CAD prior to export. For instance, if i run the BO, or Boundary, command, it reveals some areas where there are small gaps. Sometimes the SU extension, like Edge Tools, can find these but it helps to try to eliminate them in CAD first if you can.

See screenshot example:


Thank you, Eric!

I tried the BO command but I didn’t know what to do on the boundary creation dialogue box. Perhaps there’s a little how-to on how to use this specifically. So it creates an extra boundary layer and then highlights where it cannot make a boundary with red circles?

I am now over into Sketchup for the last couple of hours–I think I’m on this side now. I’m in the process of creating faces (which can’t be done automatically with Eneroth Face Creator) due to lots of uneven linework (even after flattening on both sides) and miniscule gaps.

I was using the EdgeTools Find Edge Gaps but I can’t fix any of the little circles with a double-click. I also don’t want to Close all Edge Gaps because I don’t want to create a fuzzy tolerance higher than a few inches, at best. So I’m doing it manually.

What are you favorite tools for this process?



Have you seen this yet? I have a lesson specific to this topic but since it’s part of a much longer workflow, I didn’t get into too much detail. That’s why we’re working on a CAD track now:


Wow, excellent, I will definitely check this out!

@eric-s, excellent your observation of how it was drawn in CAD file, and a clear explanation for which all those small gaps appeared, because it should not have been after the export/import I used.
A good lesson: if the drawing is not done by you, always check if it was drawn perfectly. I knew that, but I missed it this time. :neutral_face:

Chriss, Eric’s advice is to follow, check and correct in Autocad / DraftSight all those issues and then export the plan to SketchUp.

But be careful, taking into account the particularities of the drawing and the way it was drawn, only the Boundry command will not solve the problems that will arise after export / import. In some areas you will need to delete some very close lines, use Trim or Extend in other parts, and so on.