Lines not importing from AutoCAD 2018


#1

I have been using Sketchup since Version 4 and I have never had this problem. I understand that certain blocks and text cannot be imported into Sketchup from AutoCAD, but here lately even basic lines are not coming in. I am using Sketchup Pro 2018 and AutoCAD 2018. Any thoughts??


#2

Save the AutoCAD file as an earlier version. SketchUp’s importer doesn’t currently support importing of AutoCAD 2018 files.


#3

I save all me DWG files back to 2007. Even when I was using AutoCAD 2017, 16, and so on. Sketchup imports probably 98% of my lines. SEE ATTACHMENTS



#4

See the issue with the South and East walls


#5

Does this file have any AutoCAD Arch walls in it?


#6

all walls are simple lines.


#7

Hmmm, would have bet some $$ on that one. Any possibility of sharing the DWG? I would be willing to look at it. Been using AutoCAD since r12 so I have some experience with it :wink:


#8

here you goXPOOLPLAN.dwg (335.8 KB)


#9

OK at 1st glance it appears to be on SU’s side of importing the DWG file. Both BricsCAD Shape and Form-Z import the DWG as it should be. The lines do appear to be lines in AutoCAD 2019. Still digging…


#10

Everything is not quite what it seems with the file
image

When I import, I also get a layer called Area that is turned off. When I turn it on I think I see all the “missing” lines:


#11

OK let me try that. I should have checked the layers 1st, good catch.


#12

Alright, I turn that one layer back on and it came in. I then went back into AC and froze that layer and it looked the same when I brought it back in to SU. I still stand by my 1st statement, this is something in the way SU imports the DWG file.

Edit: There were 512 layers in that drawing. I did a purge command and got it down to 49. I guess the OP should start cleaning up a drawing before bringing it into SU. Something I always do.


#13

The area layer is on a no-plot layer. That may have something to do with it all.


#14

What if you move those lines that haven’t been showing to a different layer that is supposed to plot? Do they show up in the import?


#15

I took a look with AutoCad, too. What baffles me a bit are the enormous coordinates displayed in AutoCad’s status bar, even if the actual origin seems to be quite near.


#16

To SketchUp, all DWG layers are in principle equal.


#17

The walls were drawn on a C-Wall-1 layer that does print. The Area layer polyline was drawn over some of the interior walls to determine S.F. of each room. Since AREA line it was on a NO-Plot layer I guess Sketchup saw it as not suppose to plot. I removed the Area layer and it works now.
Thanks,
Allen


#18

What is probably happening is SketchUp’s “sticky” geometry: Two exactly matching lines cannot coexist, whatever their layer. SketchUp reads your C-Wall-1 layer first, then the Area layer that overwrites the previous lines. As the Area layer is invisible, Sketchup turns it off too.

AutoCad’s layer attributes that don’t have a match in SketchUp are ignored when importing.


#19

A good rule to follow is to export larger CAD files in smaller pieces – to help remove unwanted layers, styles, settings, blocks etc. Try ‘LAYISO’ for just the wall layer(s)…Then select all and ‘WBLOCK’ to write just the walls. Position remains in tact so should import right in place with your previous (missing pieces) import.
See attached screenshot of first try importing wall layer from Wblock.


#20

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.