Unable to Import a dwg from AutoCAD LT 2018 into Sketchup Pro 2018

import
mac

#1

A person in another firm who I work with frequently uses AutoCAD 2018 LT. No matter what version the dwg is saved down to (all the way to R14), I cannot seem to open the file in Sketchup 2018 or Layout 2018, no matter what settings I choose. In Sketchup, the file starts the import, the “timing cycle” icon comes up, and then the whole program crashes with no error message. In Layout, I can import paper space just fine using 2013 dwg or earlier, but if I try to import model space the system also crashes in the same way.

It is frustrating that I cannot edit the AutoCAD settings myself, but does anyone have any insight into what I could get them to change or do prior to sending a file?

Thanks.


#2

Have them save the DWG as an earlier version and import that into SketchUp.


#3

We have tried every version possible, from 2017 to R-14. All versions have the same result. A dxf of any version does not work either, coincidentally.


#4

How big is the file?
Try to import geometry only, no text or native AD families, blocks etc.
There are some issues with Layer names as well, but that is usually the other way around( export from within SketchUp to .dwg)


#5

It’s 33mb. I hadn’t checked that yet and it is seemingly huge. Thanks, we’ll try that…


#6

You might also delete any unsupported entities from the CAD file. That should at least reduce the size of the DWG. See the list here: https://help.sketchup.com/en/sketchup/importing-and-exporting-cad-files


#7

let them switch to the model space, select all and ungroup (explode) once; than save to DWG v2000.

You can do this yourself by using Dassaults ‘DraftSight 2018 Free’ version, a 2D ACAD clone (OEM Graebert).