Sketchup imports my DWG as one line instead of the whole drawing

sketchup
advice
import

#1

Hi There people,

So i’m using Sketchup pro for quit a while now (usually for urban design tasks).
Today I stumbled upon a problem i cant’s quit find a solution for. After I saved my autocad drawing in the following options ; 2000,2004, 2007 and also 2010, I tried to import it, sketchup will only draw one line on the red axe. (see pictures)

In the past i’ve imported autocad drawings way larger than this one. So I really don’t know what’s going wrong this time.

Thanks in advance for your help!

greetings!

sorry but new users can only upload one picture


#2

Entities a great distance from the Origin may be the problem.
Even a tiny reference tic can be an issue if it’s miles away from (0,0,0)

For your interest…
Importing and Exporting CAD Files — SketchUp Help
https://help.sketchup.com/en/article/3000165

Allow us to work with the CAD file if you’re at liberty to share it.


#4

Open the file back in the CAD program and Zoom Extents.
AutoCAD Civil files often contain reference geometry a great distance away from the model.

Perusing the Help article referenced above should reveal the problem.


#5

So thanks for your help.

so i copied the drawing I had problems with into a new autocad file and it worked like a charm.
I guess the first file was indeed far away from the 0 point