Sketchup Pro 2018 crashes before startup

advice
bug

#1

Hello everyone,

First Top so feel free to recategorize if i’m in the wrong place,

iv’e been using sketchup for a year now and have never had any major problems,
this morning my OS got corrupted and had to reinstall the OS and after everything seemed ready to go I downloaded sketchup again and the first time I couldn’t install it so I tried a second time and the installation went very smooth, but now I’m getting a bugsplat when I try to launch it

Any advice?
Thanks in advance.

Isaak


#2

The common reason for SketchUp to splat on startup is bad or incapable graphics drivers. Check to see that the Nvida graphics drivers are up to date and make sure SketchUp is using that card instead of the integrated Intel Graphics.


#3

Thanks a bunch i’m up and running again,


#4

What was the fix? Updating Nvidia drivers?


#5

No I updated the drivers right after I installed the OS so I uninstalled and reinstalled sketchup and selected the Nvidia for sketchup before the first startup and i guess that did the trick


#6

Very good. Likely you could have just set the Nvidia card as the default for SketchUp in the Nvidia control panel.

And to make sure, when you reinstalled SketchUp, did you right click on the installer and choose Run as Administrator?


#7

Yes that’s what I did after reinstalling sketchup,

Yes I did,

Off topic, what is the difference between right click on the installer and run as administrator or just click on run right from the download window? because I am always logged in as Admin


#8

Run as administrator allows SketchUp to make install some required stuff that Run does not even if you are logged in as Admin due to the way Windows has locked things down. See:


#9

I had this problem with Sketchup 2017 on an Alienware computer that should have been sufficient so instead of fighting I reverted back to Sketchup 2016.

I then renewed my computer (another Alienware) and upgraded to Sketchup 2018 thinking there will be no problems. The same bug splat crash occurred. I followed all of the online help and still no success. I was at the end of giving up and I bug splated for the last time.

Instead of declining to send a bug splat report I opted for yes (I never opt for yes). I opened the report and this saved me. The report said a .DLL file in my Windows 10 64 bit had problems. It gave me an option to repair my Windows 10. I opted for yes and after that not a single problem. First time in my life a computer fixed itself without my help.

I think making sure you load the software as an administrator is good advice as well. Sketchup 2018 is great.


#10

Specifically, log in to your computer with your normal user option and install SketchUp by right clicking on the installer exe file to choose Run as administrator.


#11

Sorry that is much more succinct. Yes I meant run the installer file as administrator by right clicking and selecting this option.


#12

Mine doesn’t even show the bugsplat application. It just crashes before anything starts.

the cash report says that “ucrtbase.dll” is the faulting module. Been dealing with this for a while and I originally thought it was on Microsoft’s side, but i really wanted to get help here as well.


#13

Have you done a search for ucrtbase.dll? There seem to be plenty of reports where users have the same issue with a variety of programs.


#14

Yes, only sketchup is having problems, no other programs that use it are crashing.


#15

I’m also having this issue where Sketchup 2018 will not open at all. My cursor will have the blue spinning wheel for less than a second, then go back to the normal mouse cursor.

I’m running Windows 10 1803 (17134.285). Tried uninstalling all Visual C++ installations and reinstall.

Sketchup Support asked me to search the registry but none were found. I don’t want to reimage my machine just because of Sketchup. But maybe I don’t have much choice.