SKETCHUP 2018 Pro crashes on startup - (win 10 - 2018 pro) bug splat

Hi new member here.

I have researched my problem ….and have not been able to resolve it.
Any help is appreciated.

SKETCHUP 2018 pro (and 2019) will not run on WIN 10 system –
Layout and style builder do run fine.

Right after a reboot, I get the initial screen with license options.
Once I click start using sketch up I get bug spat.
After that, I get bug splat automatically on start.

I have tried starting from start menu, desktop, sketchup model and as administrator…… none work.

WIN 64 BIT OS / VERSION 1903
OS BUILD 18362.356
DELL 7920 DESKTOP TOWER
DUAL INTEL XEON GOLD 6136 PROCESSORS
64 GB RAM
NVIDA QUADRO P4000 GRAPHICS CARD with DCH_R430 U6 (431.86) WHQL - driver updated 9.11.19

This is a NEW clean system. All other software runs fine. (Autocad, adobe Photoshop, Lightroom, acrobat X, Office, outlook, quickbooks…. Everything except Sketchup)
__
Windows is up to date.
I have updated my graphics card driver from Nvida site.
There is no troubleshoot tab to modify Graphics card acceleration – so it is per the original win install
I have reinstalled version 14.11.25325 of the Visual C++ 2017 Redistributable – and subsequently repaired it after repeated crashes.
I have uninstalled sketchup and reinstalled it as administrator

All of the above at least 2 x


Latest crash report is #463198 - “Install version 14.11.25325 of the Visual C++ 2017 Redistributable” which I did.
Sometimes I just get the generic crash report.

Did you RIGHT CLICK on the file download and choose run as administrator?

Yes I did. It crashed.

Do you have the nvidia card paired to SU in the nvidia control panel? (openGL rendering gpu)
In the nvidia control panel do you have the power management mode set to maximum?

Did you cold boot your system after the update?

I made those 2 adjustments

  1. set SU to:: “prefer maximum performance”
  2. set SU open GLrendering GPU to:: “Quadro P4000” (EDIT: I found the association with the applications, not global and reset per above)

restarted computer.
SU crashed with same error report as in original post

yes I did

I personally have v14.15.26706 installed and SketchUp 2018 and 2019 work fine.

If I was your IT, I’d uninstall v14.11.25325 and install the latest version I could download from Microsoft.
(I also think that Windows 10 came “out of the box” with a version of this MSVC library that worked with SketchUp 2018. The library has been since updated several times by MS.)

Thank you.

Well SUCCESS!!
I uninstalled the C++ Red…2017 14.11.25325 and installed the updated C++2015-2019 (x64) 14.22.27821
and she fired up.

I have spend days on this. I’m not sure why SU tells you to install 14.11.25325.

Thank you Dan for lighting the spark that there might be a better C++ option.
Thank you to all that replied!!

Cheers!!

1 Like

Thank you for reporting back, I will make sure my colleagues know what you discovered.

14.22.27821 came out in July 24th this year, making it more recent than the most recent SketchUp installer. That may be why it wasn’t suggested.

Thank you.