Sketch up Pro 2018 crashes without even starting


#1

Hi, I am new here. Writing because I do not get any help the moment from Sketch up pro 2018 technical support. No response - except a number.
Anyway:

My Sketch up Pro 2018 (lay out works) stopped starting up (goes immediately to bugsplat - however does not show details).

  1. Have run successfully Sketch up Check up - No problems whatsoever
  2. Have unstalled/installed several times
  3. In my subjective view the Sketch up worked until I updated Windows 10 Home, NOt sure though.

Please help with you advice. I am a novice with PC. Just love sketch up and designing my sailing yacht with it and parts.


#2

When you installed SketchUp, how did you do it? Did you just double click on the installer or did you right click on it and select Run as administrator?

If it was working and isn’t now, the thing to look at is what changed. Typically with Windows and Intel graphics adapters the culprit is a bad graphics driver. Rolling back to the earlier version when SketchUp worked would be a place to start. Intel graphics adapters are well known to be weak at best in their support of OpenGL. Microsoft has an established history of pushing bad graphics driver updates. Between those two, it’s necessary that you keep an eye on the graphics for your computer.


#3

Hi,

Thank you for responding and offering help.

I did just double click the icon when I installed it.

This is where my problems/challenges start – I am really not a PC guy.


#4

The correct way to install it is to right click on the installer file (the one you downloaded) and choose Run as administrator. Not doing so can create issues. I would suggest that you do that now. You don’t need to uninstall SketchUp. Just find the installer, right click on it and choose Run as administrator. Then when presented with the option, select Repair.

See if that changes anything. If not, then you need to look into the graphics drivers.


#5

Thank you again.
I just tried to reinstall it, with right click. No help – again bugsplat. I have did run the Sketch up Check up program - All is ok, even the graphics.

I do have another graphics card AMD on my PC. How can I try that one? Any advice.


#6

See if you can right click on a blank part of the Desktop and bring up the control panel for that graphics card. There’ll be some method for setting it so SketchUp will use it instead of the Intel chip.


#7

I will try…


#8

Hi, I tried to change the setting in AMD piece of software, probably not much happened…

I am still puzzled…


#9

How old is your AMD driver? The ones from this spring seem generally to work.


#10

I have same problem with SU pro2018. I try use older version SU 2017