SketchUp Pro 2018 and 2019 is not responding


#1

Hi there,
I don’t have a lot of experience with sketchup because I am learning how to use it for 3 weeks. I am owning laptop which in my opinion has more performance than it is necessary to use sketchup without issues like mine (dell xps 9560 win 10 / i7-770hq, 16gb, 512gb m.2 (180gb free), geforce 1050ti, 4k).
Around a week ago I started experiencing some issues which don’t allow me to continue my sketchup learning. My sketchup instances (2018 and 2019 both) stop working when I am trying to use explode on new file with only one model freshly imported from 3d warehouse - i.e.: “Bed nam3dpro” or “Misura emme bed 01”. I check all options like:

  • uninstall and fresh install with as administrator option,
  • OpenGL (fast - check),
  • set Nvidia as a graphic processor for sketchup
    My computer is running on the freshest nvidia/intel drivers . I’ve got all MS kb installed.

Could someone check if that models causing issues like I’ve described above on his/her computer ( “Bed nam3dpro” or “Misura emme bed 01”)? I know they are big, but I didn’t experiencing this issue earlier.
Do you have any ideas what I could check to get rid of that kind of issue?

Have a great day, mn


#2

Why do you need to explode the imported component ?
You can select it and use the context-menu to Edit it…
Once inside the component’s context you can do whatever changes you want, then exit the editing-session back into your Model’s context.

If you Explode a very complex component or group then it can take a while for it to complete, so do not confuse the pausing of SketchUp during an ‘Explode’ operation, with SketchUp ‘breaking’…


#4

However as TIG said, is better to work without exploding – I have been able explode “Bed nam3dpro”, but it takes about half an hour. During that time you can’t work with SU, it will not responding for sure.
Exploding the cca. 150k edges & 100k faces takes time even with the best hardware.

a ) See answer from TIG
b ) Patience… :wink:

+1) 4k displays are great but consumes more hardware resources. Windows and most of the programs still can not handle the high resolution scaling properly.


#5

Exploding one of those particular models is some kinda of indicator for me if my instance of sketchup is working properly or not - I know I can just edit it @TIG :). From around week ago my sketchup 2018 starts being extremely slow with every action what I’d like to perform. All my models starts lagging even they are working like a charm week ago. Even moving models in project is lagging.

@TIG, @dezmo
Do you have any ideas what can cause this issue and how to repair it?


#6

Has a recent Windows auto-update affected your GC drivers ?


#7

Not sure what GC drivers means. GF (GeFroce?) drivers… ohh graphic card?
I’ve updated to the newest one today using Nvidia tool and I don’t think windows updated by itself during last weeks.
Nothing has changed :(.


#8

Then I assume there were an “uncontrolled” Windows update what may changed your drivers.

  • Check on Dell site if they have newer drivers
  • Try to check again if the Nvidia still assigned to SU. In Nvidia panel as well as it SU Preferences>>Opengl>>Graphics card details.

Don’t give up! Problem solving, or at least understanding will always be a good way to learn! :beers:


#9
  • Check on Dell site if they have newer drivers

What kinda drivers do you mean only GC? I’ve get the newest from Nvidia (25.21.14.1935 ) dell support shows 23.21.13.9125 as the newest. I don’t have the latest bios but it shouldn’t cause this issue.

  • Try to check again if the Nvidia still assigned to SU. In Nvidia panel as well as it SU Preferences>>Opengl>>Graphics card details.

I did this two times today. I did even more: I’ve changed it to built-in integrated Intel card + restart, changed again to High-performance Nvidia processor + restart. As for now is set to High-performance Nvidia processor.

I am wondering if there was other Microsoft KB which is causing my issues… but I cannot find anything about it in Internet.


#10

Your Nvidia seems to be a latest.

Not easy to get solution since there are a several reason may causing it, unfortunately sometimes reinstall the windows is the only solution, however I don’t like to offer this just at the very last resort…

Some more idea to check:

  • Have you got an external monitor connected since the problems started ? (I had some performance problem if the scaling settings (in Windows) of external monitor was not the same as the internal.)
  • You may have to check the power setting in windows. Performance setting of CPU/GPU when working on battery or mainly if power cord plugged in.
  • You may had more simple drawings when you started to learn, and now you are trying more complicated objects to deal with…!?

#11

External monitor/scaling:
I am using only display integrated with laptop. I didn’t change scaling in last month.

Performance : highest on power cord, I didn’t notice difference with or without power connected.

Complicated objects : I am using it as a indicator which is telling me that many simple objects in my scenes won’t work at least acceptable. That examples worked a week ago.

I don’t want to reinstall windows that’s why I wrote this post. I have a couple of trial days to pick my future environment and I want to test SU but it doesn’t wanna cooperate :frowning:

Nicole