SketchUp Pro 2017 crashes while exporting 2D graphic

SketchUp Pro 17 crashes when trying to export 2d graphic. I just upgraded from 2016 MAKE. The model that I am trying to export the JPEG from exports just fine in MAKE 2016. Here is what I have tried:

  1. changing hardware acceleration but interface is different than previous versions of SU so I can’t just turn off. Tried to adjust settings to no anti-aliasing and turning fast feedback off. Didn’t work.
  2. rendering on screen size setting rather than 3600 pixels wide. Didn’t work
  3. rendering without shadows. Didn’t work.
  4. rendering simple 3d extruded shape. Did work.
  5. updated graphics card driver to 2/17 driver. Didn’t work.
  6. Restarted computer. Didn’t work.
    I can export this same file in Make 2016. So why is SUP17 crashing if Make 2016 will render it just fine?

Are you working with a laptop?
Many laptops have a discrete graphics card (your ATI Firepro V) and an onboard graphics chip.

In SketchUp, click… Window > Preferences > OpenGL > Capabilities (Graphics Card Details button)
There, confirm SU is being rendered by your ATI Firepro V and not the onboard graphics chip.

No, I am working on a desktop.

“Compatibility Profile Context” ???

Does SketchUp 2016 say the same thing for OpenGL Details ?

Does the JPG export crash produce a BugSplat! report, did you send it in, and what identifying info did you use so it can be looked up in the splat database ?

Are you using Windows display scaling on a High DPI display ?
(IF so, is it set above 150% ?)

Have you tried another format such as PNG ?

(SketchUp uses a number of image libraries, and perhaps you can workaround by temporarily using another format, and if need be, converting to JPG in an external application.)

Run the SketchUp Checkup utility, and post the .sulog archive here in this thread.
(Keep it in case you open a support ticket, as they may ask you for it.)

1 Like

Thank you for your diagnosis help on this.

Here is what the 2016 screen tells me:

The bugsplat! screen doesn’t come up. This is the only thing that comes up:

I just tried it in a PNG format and had the same crash as with the JPG.

Hope this helps to clarify things.


Here is the Checkup screen shot as well:

  1. Oh, you have SketchUp 2016 set for CPU rendering (ie, hardware acceleration is switched off.) SketchUp 2017 does not allow this.

  2. That screenshot is not the .sulog file, but what it would show would be details and driver version etc.

  3. When you installed SketchUp did you right-click the installer and choose “Run as administrator” ?

If you are up to the latest available FirePro driver, then I’d say contact technical Support and open a ticket.

Here is a followup to the problem that I had with SU17 crashing.

My computer has an AMD Radeon Firepro v4900 video card. We have several computers in the office and all of them have the same video card, but only two of them were having problems. Our IT consultant checked the driver versions on each (one had 15.xx drivers, another 14.xx, another 13.xx, and another 8.xx). The version 14 and higher drivers were the ones that were causing video card driver crashes when exporting from Sketchup 2017. Installing the 13.35 drivers on those two computers resolved the issue.

Thanks for all of the help. This one was a tricky one. No problems since.

1 Like

@mchandler There you go Mark some usefull info for AMD FirePro driver.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.