Sketchup Pro 2014 Bugsplat at Startup

I submitted an bugsplat report that I need help with. In process of generating a model, I was attempting to import a .tif file into the model. It came up with options for the import which included something to do with material. I selected it since the .tif file was scaled. This created an error somehow which is not allowing Sketchup to load now. Please help. Thank you.

Hi Michael-

I see your bugsplat report (#664155). It’s an interesting one, because you’re the only person who has ever encountered it in SketchUp 2014.

The crash is happening in the video card driver “ig8icd32”. Is there any chance that your video card driver was updated recently? If so, try rolling it back to the previous version. If this is a new machine, try updating your driver.

Does this crash only happen with the model that you were working on, or does it happen all of the time? Try starting SketchUp by double-clicking on a “known good” .skp file to make sure that it’s not just getting stuck trying to restore your previous file.

-m

Marc - I will send this along to our admin folks and see if they can update the driver. The driver is dated 2015.

Marc - The video driver has not been modified and I have used SU on this laptop several times over the past year without incident. It happened when I was importing a scaled .tif that showed the equipment layout on a structural frame in order to position the model components. This was the first time I imported a picture and it came up with a material option that I wasn’t familiar with and selected it by mistake. When I tried to stop the import, it presented the model in a two point perspective view, which looked extremely skewed. I closed the program and tried to restart it… that’s when it gave me the error. It does it every time now… I can’t even get to the startup screen. Is there a way and opening the file without it trying to open the last file?

Update… just updated my Intel video driver to the latest and it still generates a Bugsplat on opening. I submitted a new bugsplat report. Need help, please

Do you still get the crash if you start sketchup by double-clicking on a .skp file to open it directly?

Marc – I tried both opening a known good file and double-clicking and both end up with a bugsplat. Any other ideas? This problem was started when trying to import a large .tiff file into a model… when my administrator reloaded the software, he was able to open in from his desktop just fine. When I logged back in, it gives me a bugsplat. Thoughts?

If your administrator can run on your machine, then this isn’t an issue with your video card. It must be an issue with some of the files that are specific to your user.

Rename or delete these folders (if they exist on your machine) to see if it makes any difference:
C:\Users\marmstrong\AppData\Local\SketchUp\SketchUp 2014\SketchUp
C:\Users\marmstrong\AppData\Roaming\SketchUp\SketchUp 2014\SketchUp
C:\ProgramData\SketchUp\SketchUp 2014\SketchUp

And temporarily move all of the files out of this folder into a temporary location:
C:\Users\marmstrong\My Documents\

You may also have some luck running a program monitor such as FileMon, which will tell you which files SketchUp is accessing as it starts up. The last file that it touches before it crashes is probably the source of your problem.

-m

Did as you suggested. Loaded Process Monitor and ran it… I filtered for SketchUp.EXE. See attached tab delimited txt file.SketchUp.txt (1.1 MB)

I also did the other things you suggested with the folders first.

Tried it a different way… still learning how to manipulate Process Monitor. This file activity from the startup of SketchUp.exe through the end of the bugsplat showing file system activity and process and thread activity (tab delimited).SketchUpFlow.txt (49.1 KB)

One last thing… I downloaded SketchUp Pro 2015 and 2017 to see if either of them would work. They at least open to the ‘choose template’ screen. Clicking ‘Start using Sketchup’ goes straight to a bugsplat.

I see your crash reports for SketchUp 2015 and 2017 - they are crashing in the 64-bit version of the same library as your previous crashes (ig8icd64). I don’t see anything particularly suspicious in the system logs that you shared.

When your system administrator runs SketchUp on your machine, is he/she running it while sitting at your machine? Or from a different location using some sort of Virtual Desktop software?

Ok, one last thing to try - download and run the “Checkup” tool for SketchUp - it will exercise your video card to report whether SketchUp will run properly on your system. If it fails, it may give us some more information. CheckUp is available on the regular SketchUp download page.
https://help.sketchup.com/en/article/3000318

The system administrator was not at my desk when they ran it. They logged in from another location using their PIV card access. This must have something to do with what I was doing when it first crashed. Like I mentioned before I was in the process of importing a .tif file (that I didn’t realize was nearly 60MB). When it gave me the option of how to use it, I selected texture for some reason to see what it would do. It attempted to load it then locked up. When I restarted and tried to open the file again, the file was displayed in a two point perspective and very skewed. When I tried to make a change to the file, it locked up again. It never started right again.

Here is what Checkup provided:
Results:

Success: System RAM requirement has been met!
Success: Operating system version requirement has been met!
Success: Graphics card RAM requirement has been met!
Success: Graphics card OpenGL requirement has been met!
Success: Graphics card Hardware Acceleration requirement has been met!
Success: Graphics card capability tests have passed.

Congratulations, your computer has met all the minimum requirements to run SketchUp 2017.

Ok, that’s interesting. Virtual desktop connections usually provide a different type of access to the video card, which could potentially bypass an issue that you see locally.

I know that it seems like this issue started as a result of that .tiff you imported, but I’m having trouble figuring out how that would result in a crash at startup. Everything else points to an issue with the video card.

I’ve lost track of exactly what we’ve tried so far, but if you have the original SketchUp 2014 installer and your license info you could try removing the old install and re-installing it.

Here are the last-ditch things I would try:

  1. Create a new user account on the machine. Try to run SketchUp logged in to that new user account.
  2. Remove the video card and install a different one, even if it’s just temporarily borrowed from a different machine. Try running SketchUp again.
  3. Find the SketchUp section in the Windows registry and delete it. Try running SketchUp again.

After that, I’m afraid I’m out of ideas. You’re a pro user, but you’re on an old version… Still, you could try putting in a support request because SketchUp 17 doesn’t run on your machine either.

Marc

OK… long story short. I was finally able to open the software without the bugsplat. Not really sure what step did it, but I removed the Sketchup folders in the registry as suggested. It locked up several times after that, but I tried opening a file that I knew was good and it at least opened to the startup screen and asked if I wanted to update. I started a new untitled file and saved it. That seemed to do the trick. It is working for the time being. Thanks for your support.

One more thing that I did… when it finally opened. I went to window>model info>statistics and selected purge unused and fix problems. Maybe that helped… : )

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.