Sketchup Plugins all error

After a BSD on Windows 10 - all plugins error.

I’ve un-installed - removed files in appdata, programdata and programfiles - then re-installed. Same issue.

I also uninstalled Visuall C++ 14 (2015) and re-installed from MS direct download - no dice.

I also did a c:\sfc /scannow - did not help.

Starting Sketchup in a new user profile works.

Also, shift+right click icon in broken profile > run as different user > use new profile creds > plugins run fine.

What could be causing this? It’s an old issue i’ve seen other people in the forums, but the threads are closed.

This is actually the 2nd time it’s happened to me, i use Sketchup a lot so it’s important for me to figure this out. I cant keep creating new profiles when it happens.

Is it possibly and environment variable?

It’s interesting i can be logged in to the broken profile and start sketchup as the non-broken user and it works fine - anyone have any ideas?


What do you mean by all plugins error ? can you tell more about it ?

If creating a new user resolves your troubles, I’d say one (or more) of your plugins messes things up.
Starting sketchup with shift+right click > run as a different user is going to load plugins from this user’s own appdata folder. (username > appdata > roaming > sketchup > sketchup 2018)
have you tried replacing this content from the “working” profile to the “broken” one ? (you’d have to reinstall your plugins if you do so)

Two things I’d be asking, what caused the BSD.
Did you originally install Sketchup using the method that avoids permissions issues?
That is, right Click on the installation exe and choose Run as Admin.

What version of SketchUp are you using? Please complete your profile.

When you reinstalled SketchUp did you right click on the downloaded installer and choose Run as administrator from the Context menu?

i’m using 2018.

Yes, i went through all the steps outlined in this thread:

The resolution in the thread above was to create a new profile. Which made me think of running sketchup as that user in the broken profile, which does not throw the errors.

It’s a fresh install with default plugins and i get these errors on load:
Error Loading File C:/Users/td/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/su_advancedcameratools/actloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/td/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/su_dynamiccomponents/ruby/dcloader.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/td/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/su_sandbox/sandboxmenus.rbe
Failed to read RBE/RBS file.
Error Loading File C:/Users/td/AppData/Roaming/SketchUp/SketchUp 2018/SketchUp/Plugins/su_trimble_connect/boot.rbe
Failed to read RBE/RBS file.

@Box asked you this question, but you haven’t answered it.

The symptoms you describe can be caused by NOT doing this.

Try it. It doesn’t need a full reinstall. Find the downloaded installer .exe file (probably in your Downloads folder).

R-click on it, choose Run as Admininstrator, and when prompted, select Repair.


I ran as admin when I installed, it was one of the things in the thread I went through. I went ahead and followed your instructions anyway but it didn’t help : /.

Have you tried updating those extensions through the Extension manager, or downloading from the Extension warehouse and installing them.
They are the ones shipped with Sketchup, so it suggests there is something wrong with your installation.

If the previous did not work and the following does work

It would suggest that the user profile that caused the errors is corrupt. You will have to create a new profile and migrate all the windows pieces and parts to the new one. Google can help find the directions.

1 Like

The specific extensions listed in your report are all standard ones from Trimble that come as part of the SketchUp package. They are automatically copied from the program source when you launch SketchUp if they aren’t found in your Plugins folder. Try deleting those extensions while SketchUp and then relaunching it. If there is an issue with bad copies in the Plugins folder, that should heal it.

Yep, it’s the same conclusion as the previous thread I mentioned. I was hoping there was possibly some other insight to what is actually causing the issue within the broken profile… instead of having to create a new profile. Sketchup is the only thing that is broken, every other program works as usual.

On the surface it seems like it’s something really simple. Like a system variable or missing pointer for running ruby or something.

It’s not the plugins unfortunately. It’s the windows user profile. Something broke or has been misplaced and is causing the the errors.

Are you sure? Plugins are saved separately per user, so this is an example of how a single user profile could be contaminated.

But it’s a fresh installation, and this same installation works for the new user. I created the user before i installed Sketchup. I mean to say is that I only just created the new user profile so that i could use SketchUp to get some work done.

I tried uninstalling and installing a few times doing different things, like removing all old SketchUp files after uninstall to ensure a fresh install, also ensuring that it was installed as admin.

These are all default plugins from the installation.

I think it’s the user profile.

The SketchUp installer does not clean out the Plugins folder for a user profile when you uninstall or reinstall, it only replaces the app itself. So, if the first profile got bad copies of these extensions, they will still be there until you manually purge them yourself.

I manually removed all sketchup associated folders before re-installing. In Program Files, AppData and also ProgramData folders. I even did a quick look in the registry. Clean wipe, clean install.

can you try :

  • cutting your plugin folder in “broken profile”/appdata/roaming/sketchup/sketchup 2018

  • copying it in programData/sketchup/sketchup 2018/sketchup (no plugin folder should be there till then)

  • restarting sketchup

Darn, it didnt work.

I see that it re-made the plugins folder in AppData upon starting Sketchup, although the issues persists :.(.

Thank you for the suggestion, it’s cool to learn that trick.

I upgraded to 2021 - same issue