SketchUp operations are extremely slow on new ssd computer


#1

All operations are extremely slow on a brand a new machine. It has two ssd hard drives, C an D. The hardware is more than adequate. I bought it because it should be lightning fast. Our models work great on all our other machines, even the older ones. The graphics card is NVIDIA GTX 980m and SketchUp is set to use it. It does not matter if hardware acceleration is on or off. SketchUp tech support and the computer manufacturer have exhausted all their ideas. Our computer tech thinks it could be because it is set up with Raid 0. I’m really struggling, can’t get any work done. Any suggestions? Thanks!!


#2

Sounds like a really nice machine. Too bad; I’d be terribly disappointed. What kind of processor does it have? Are you saying that even disk access processes, such as writing a data backup, are slow? Is the manufacturer going to try making you happy, as by offering a generous trade-back on a suitable machine, or is he just going to act baffled?

-Gully


#3

Processor is Intel core i7-4790K CPU @ 4.00 GHz, 4001 Mhz, 4 Core

Operations like moving, copying groups and components, any operations in SketchUp are extremely slow and the blue wheel comes up. The outliner flashes blank and populated several times with each operation.

I’m not sure yet what manuf will provide. I’ll cross that bridge if a solution doesn’t present itself very soon.


#4

All other programs run fast.


#5

Yow.

I would imagine so.

-Gully


#6

Have you tried disabling extensions? I have the same processor and recently I experienced very odd behaviour and freezing. The culprit was an extension (BIM Object).

By the way if you haven’t done so already I would download the Sketchucation Plugin Store extension which is great at managing extensions including disabling and enabling extensions. http://sketchucation.com/plugin/696-sketchucationtools

If it’s not extensions and you suspect it is RAID then you could try changing the settings in the BIOS to temporarily disable RAID. It may take some input from your IT people and/or the PC manufacturer however so you don’t mess anything else up.

You could also try re-installing SketchUp, although I imagine you’ve tried that. However you could try re-installing and running it from a plug in portable hard drive. This would rule out whether there is any conflict with the SSD.


#7

don’t mess with RAID until you know what you do, wrong settings can render your data medium inaccessible… and also not very reasonable because a RAID is transparent for every application, i.e. SU is just not aware of it.

I would presume extensions/plugins too, especially if copied from an old SU version/installation to your new system.

Open “Window > Ruby Console” and do a

Sketchup.plugins_disabled=true

for disabling them all and check with

is_disabled = Sketchup.plugins_disabled?

if deactivation was successful.


#8

This doesn’t sound like it has anything to do with the SSD - SketchUp shouldn’t be reading or writing anything during those operations. As @Kenny suggested, the first place I’d try is disabling all plugins and extensions to make sure a misbehaving one (especially one with observers) isn’t the issue. If performance is still bad with no extensions, I’d do some testing to make sure the issue isn’t with the OpenGL operations on your graphics card or the communications between the CPU and graphics card. Have your tech get the NVIDIA performance testing app (https://developer.nvidia.com/nvidia-perfkit) and see if that indicates a problem.


#9

As I say I have the same processor (and 32 GB RAM). If you would like to try a test, open the attached file and run the sandbox from contours on it. It takes just over 2 minutes on my PC for it to complete the action. I’m no expert but I don’t think that this should be influenced by the graphics card, it should be mainly the memory and processor doing the work. If it completes it in a similar time then you will know that it is likely to be the graphics card rather than processor/memory causing the issues. If it is very slow to complete however then it could be the processor and memory handling in SketchUp (as well as the graphics card possibly for your other issues).

Incidentally I tried the same file on my 4 year old laptop which was no slouch in its day and it took nearly 14 minutes to complete! The file is an exploded CAD file with lots of small line entities. If anyone else wants to try this I’d be interested.

Sandbox test.zip (1.1 MB)


#10

A Raid 0 array cannot be “temporarily disabled”; therein, data is striped across both drives.
Lose one drive in a Raid 0 array; lose all.

Raid 0 is rather risky business IMHO, vs. a redundant Raid 1 array of mirrored drives.
Lose one drive in a Raid 1 array and you lose nothing but the hardware and the time it takes the controller to rebuild the volume on the replacement.


#11

Thanks for all your suggestions.

Yes I have reinstalled SU multiple times on both C and D drives.
Extensions are all disabled.
The Sandbox test completed in under 2 mins. I agree, I don’t think it’s the processor.

I will run the perfkit from NVIDIA. The IT ran something similar but this one looks more complicated. I’ll have him run it. That sounds like a good possibility.

Does anyone else have a Raid 0 setup? And experiencing similar issues?


#12

You might have a look at this topic…


#13

The Outliner is notorious for slowing operations down. It should never be open, unless you are specifically using it.

This would include:

  • Inspecting group and component nesting.
  • Selecting objects (especially hidden ones you can’t select in the model view.)
  • Moving objects from one edit context to another (when it cannot be done easily in the model view.)

Close the Outliner or roll it up before intensive model operations.


#14

SketchUp writes to the Undo log files in the User’s %LocalAppData%/Temp directory.

There is a hidden registry entry for number of undo operations:
HKCU\\Software\\SketchUp\\SketchUp 2015\\MaxUndo
It is set to 100 (0x64) by default.
As a last resort, (assuming the setting is actually used and not just a leftover from some legacy code,) it could be set to 0 whilst SketchUp is closed, and try the intensive op again.

Regarding RAID, I’d try going into the RAID Manager during boot, a see if the array needs syncing or other maintenance.
I agree with Geo a mirror array makes more sense in a system with only 2 drives.

Lastly, I’d see if the SSD manufacturer has a low level test utility that can be run on the drives.


#15

While Su is running open task manager, select the performance tab, select the resource monitor. That will bring up several split screens allowing you to get idea of internals. It sounds like there may be memory leak of some type.
The max speed is around 3.5GHZ, are you over clocking you PC.
SU Is not the only app running. Try shutting down other then required ones at start up. Until you get this sorted out I would turn off check for up dates, transparency, auto saves etc.
I changed my SSD so it is used only for the operating system and the library file storage is saved to drive D. I have a 2T hard dive however.
Why Su only issue, but do not get stove piped on just the drive issue.


#16

This might be a lame suggestion but the last time I got a new computer someone had forgotten to enable all the cores of the processor. The multiple core are off by default. It’s in the System Settings somewhere and I don’t remember how to get there. It’s such an obvious thing it’s easy to overlook.


#17

if they are from the common Samsung Evo/Pro series the Samsung Magician application can be used for a performance benchmark of the drive… at least if the RAID doesn’t prevents this.


#18

I’m still puzzled why everyone seems focused on the SSD? The OP said that only SketchUp seems affected, and I don’t believe that SketchUp accesses the drive any differently than other applications. I can think of no reason why the OS or SSD would single out SketchUp for punishment. What am I missing?

Whatever is going on, shouldn’t there be a flurry of error messages getting posted to the system logs?


#19

…


#20

I focused first on the fact he had the Outliner open.