Sketchup not working on brand new $3000 laptop

bug

#1

Hi! First post here :slight_smile:

I’ve just bought a brand new Lenovo Yoga C930 UHD 14" i7 2-in-1 Laptop (16GB ram, 8th-gen intel i7 processor) that cost about $3000 … and sketchup doesn’t work on it.

I can install and open Sketchup fine, but when I open it I:

  • don’t see any of the modelling axes
  • can’t draw anything

In this image, those boxes are not actually boxes. They’re the selection boxes made by using the mouse - none of them actually select anything and they stay on the screen even though they should go away as soon as I release the mouse.

I’ve uninstalled and reinstalled sketchup multiple times, restarted my computer, etc. Still not working.

I’ve been using Sketchup for years and have never encountered this issue, even on lesser laptops. Can anyone please help me out?


#2

Go to Window/Preferences/OpenGl and untick Use fast feedback.


#3

Legend! Works perfectly now :D. Thank you so much and have an awesome day!


#4

I’ve had a few of these recently. It’s very gratifying to turn someone’s world around in three mouse actions.


#5

It’s not all good news, although it allows Sketchup to function it’s actually telling you that the Graphic Card in your new computer isn’t really up to the job. SU relies heavily on the graphic card and it recommends against using built in Intel cards.
If you bought this laptop specifically to use Sketchup I would suggest you take it back and exchange it for one with a dedicated graphics card, preferably Nvidia.


#6

I’m sorry @colin I don’t find it at all gratifying, I find it sad that the persons computer won’t cope very well with Sketchup.


#7

There is some sort of detection going on, where SketchUp feels like it’s dealing with a capable GPU, enables something that can’t work, and then the user gets a blank screen. Either Intel or SketchUp ought to be able to either clearly say how powerful the GPU is, or detect that the GPU isn’t as powerful as it claims to be.

Or reverse the settings. Have that option off for everyone, and include it as a tip for people trying to get good performance on better GPUs.


#8

@jed.herne , are you sure the laptop doesn’t have a second video adapter?
I have a upper end laptop that for a long time insisted on running sketchup with intel graphics.

Shep


#9

This wold be interesting to try, on a Surface Pro that has the problem. See if there is another GPU that can be selected:

https://www.howtogeek.com/351522/how-to-choose-which-gpu-a-game-uses-on-windows-10/


#10

Only the high end Surface Pro has a second card and that is an Nvidia.


#11

Good to know, I may suggest that if it’s an option.


#12

Here’s a post from when I tripped over the solution.

https://forums.sketchup.com/t/jagged-lines-on-brand-new-computer/19162/7


#13

Yep, and that option won’t be there if they only have one graphic card.


#15

It’s worth noting that SU does mention the intel issue in its Hardware recommendations.


#16

The intern Intel does seem to infect Windows, merely

When I’m Not DOing Work i’am updating Stuff


#17

As far as I could find out, all the Lenovo Yogas come with only an integrated Intel graphics chip. What you pay for is the form factor and design.