Cannot See Any Drawing


#1

Very much a beginner here. I had created a few very basic sketches without a problem, but now when I go in to create a new sketch I cannot see anything I draw. Also happens when I open one of the sketches I previously created. Sure it is a very simple fix, but I am stumped. Help!


#2

It is possible that Windows 10 snuck in an update that replaced your graphics driver with one that is not compatible with SketchUp (there have been a lot of reports of that happening, especially with Intel integrated graphics). See if you can either roll back the driver or get a newer one from Intel and see if that helps.


#3

I cannot roll back the driver on this laptop, is there another graphics card besides the intel HD Graphics 520 that I should install. Thanks in advance for responding.


#4

The Intel HD 520 graphics adapter is not especially high performing according to the various benchmark sites. You might try updating the driver directly from Intel and that may or may not help.

You would first want to check that it’s actually possible to install an additional graphics card. If so, look for a GeForce GTX series card from Nvidia. Historically they have provided the best OpenGL support.


#5

In Sketchup Preferences>OpenGL
Toggle the “Use Fast feedback”


#6

I have a related problem – inadequate graphics in a laptop. I find myself having to zoom in dramatically to separate drawn elements so that the Select tool can distinguish them. The laptop uses an Intel HD Graphics 4600 chip running a 1920x 1200 display, but it looks like I could do better with a real PC dedicated to Sketchup. Just how much graphics power do you really need? Somewhat related, is there any work being done to support Sketchup on a Linux platform?


#7

A lot of that would be a non-issue if you were to take the time to use groups and components.

Get a computer with a current GeForce GTX series card.

It’s unlikely there’ll be a desktop version for Linux but the only people who know for sure can’t and won’t say until it happens if it ever does. The alternatives are the web-based versions.


#8

Now this is getting downright scary - the Web knows everything. This morning’s email from Newegg touted an “EVGA GeForce GTX 1070 Ti 0 Ti SC GAMING Black Edition Graphics Card - 8 GB GDDR5 - 256-bit - 1607 MHz” for the low, low price of $349. This looks like an old card, so they’re probably they’re going to announce a new version shortly, but it gets good reviews. A local buddy is a state-of-the-art gamer, so he might have an old card of some kind lying around I could use.

But, (thanks, @dezmo) I’ve discovered preferences (I really have an AMD Radeon HD 8690M, with no OpenGL warnings) and a whole new line of study to occupy my (hah!) spare time. Sketchup is turning into a full-time job.


#9

Figured out this problem at least. Went into Window/Preferences and then unchecked the box “Use Fast Feedback”.
Works great now…