I need help. Something is wrong with my display

It was working fine before. Today however, when I opened it, the displays are like these. i dont know what happened. My graphics card is up to date. I’m using AMD Radeon 535 Windows 10

Make sure SketchUp is using the AMD card. Look in the AMD graphics control panel. If you can see the Window menu in SketchUp, go to Preferences>OpenGL. Try changing the state of Use Fast Feedback. You might find that you need to roll back the graphics drivers.

FWIW, according to the various benchmark site the Radeom 535 is not a real high performer. If your computer has an Intel GPU also, you might give that a try and see if it works any better. It may not but you won’t know until you try.

here’s the OpenGL info on my sketchup. how do i know if my computer has an ntel GPU?

Well what cpu do you have? :wink:

Did you try changing the state of Use Fast Feedback?

As for the Intel GPU, look at your computer’s system information.

AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx (8 CPUs), ~2.0GHz

1 Like

System Information

  Time of this report: 6/11/2020, 09:21:07
         Machine name: LAPTOP-I8R7PUS9
           Machine Id: {EF220AEA-360A-45CB-BD24-DA40AF8990E9}
     Operating System: Windows 10 Home Single Language 64-bit (10.0, Build 18362) (18362.19h1_release.190318-1202)
             Language: English (Regional Setting: English)
  System Manufacturer: Acer
         System Model: Aspire A315-41G
                 BIOS: V1.03 (type: UEFI)
            Processor: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx   (8 CPUs), ~2.0GHz
               Memory: 4096MB RAM
  Available OS Memory: 3484MB RAM
            Page File: 4603MB used, 6816MB available
          Windows Dir: C:\WINDOWS
      DirectX Version: DirectX 12
  DX Setup Parameters: Not found
     User DPI Setting: 120 DPI (125 percent)
   System DPI Setting: 120 DPI (125 percent)
      DWM DPI Scaling: Disabled
             Miracast: Available, with HDCP

Microsoft Graphics Hybrid: Supported
DirectX Database Version: 1.1.5
DxDiag Version: 10.00.18362.0387 64bit Unicode

it was already in “use fast feedback”

It would be in the OpenGL panel that was behind the window showing the OpenGL Details.

Since this was working and isn’t now, the thing to look at is what has changed. SketchUp 2019 didn’t change recently so it’s like a Windows update that screwed with the graphics drivers.

So try changing the state of that setting. Turn off Fast Feedback.

must have been the windows update. didnt have a problem before. and i remember updating my driver and this happened. but it is up to date now. i dont know why it would show up like this if my driver is updated.

Could be a broken driver. As I said earlier, you might need to roll back to an earlier driver.

Maybe just doing a cold reboot of your computer would take care of it.

1 Like

already did that. still the same.
i also tried to turn off “use fast feedback” still the same

Next step is to try rolling back the graphics drivers to a version that work.

It’s unfortunate that your computer has a GPU that ranks so low in performance benchmarks. Maybe it’s time to save your pennies for a new computer. Or at least a respectable graphics card if the Radeon card could be replaced.

Seems to be on-board or that is what I saw while looking it up. :frowning:

I’ve seen that before, many years ago, was a result of damaged GFX RAM, overclocking that went too far and damaged the hardware. Not saying that is what happened here, merely drawing a comparison.

I too would vote to roll back your GFX driver to a previous version.