Sketchup not updating changes


#1

This is a difficult problem to explain. Basically, any changes I make with the program (orbit, draw, edit, anything) will not show until i click something else. I have a powerful enough computer to run it well. 2.4 GHz quad processor, 8 GB RAM.

I’ll try to explain further. I just downloaded sketchup (have been using it for years on other systems). I immediately noticed something wrong when I loaded it for the first time. I tried to rotate the screen and nothing happened. I tried to rotate again, and there was slight movement. At first I assumed it was just moving agonizingly slow. But, after some more attempts at getting it to work correctly, I noticed that it only showed what my last action was, after trying to take another action. As you can imagine that is a nearly impossible working environment.

I tried uninstalling and re-installing, restarting my computer, ect, but nothing seems to have fixed the issue. If anyone has any further ideas, please let me know.


#2

Try the program with ; Use hardware acceleration’ off to bypass your graphics card.
(menu Window > Preferences > OpenGL > disable 'Use hardware acceleration’n and restart SketchUp).

If it helps (slower with larger files though), then see if you can find another driver for your graphics card to better support OpenGL.


#3

#4

This appears to do the trick. Although I do not know why this was necessary, since I have a fairly decent card, GeForce GTX 850M with latest drivers. It’s a laptop, but much more powerful than my previous laptop, which ran Sketchup just fine.

In any case, thank you for the help.


#5

Laptops often have an Intel graphics chip in addition to the “real” graphics card, and Windows often pripritizes the Intel chip to save power. You could check in the Nvidia control panel 3D application settings that SketchUp is set to use tha Nvidia card. The “automatic” setting sometimes doesn’t work.

Anssi