Sketchup not launching, bugsplat

I have an issue with sketchup2020, every time i open a new model, or reopen a model sketchup either doesn’t launch, or simply crashes with the bugsplat window. I can however access the splash screen when you either open recent models or choose a template to start modeling, but i can not get sketchup to open beyond that
I do not know when did this start honestly, it’s been a while since i used sketchup on my personal PC
I tried reinstalling sketchup, i read that it might be a graphics card issue i reinstalled my graphics driver, did a clean install, and even changed from studio ready driver to game ready driver to see if it helps, i got my hands on an older and newer version, 2018 and 2022, and I got the same problem
I even tried to change the setting in my Nvidia Control panel, but it did not work

what could be causing this issue, how can i fix it ?


If my translation is correct, i can open the sketchup (i believe it is called) “Home” display,

But if i open any file or new model i get the bugsplash immediately

This topic was automatically closed after 186 days. New replies are no longer allowed.