Sketchup not drawing entities [solved]


#1

Hi Everyone,

Woke up this morning to start some SU work and tried to draw a rectangle in a brand new file and NOTHING … though I was dreaming so tried again NOTHING… tried a line NOTHING. tried a circle NOTHING…

Hmmmm, W10 just did an 1803 update but surely it couldn’t be that ?

So opened another file NOTHING.

Changed my mouse NOTHING

Changed my mouse again NOTHING

Updated my GTX driver - NOTHING

Did a SU repair NOTHING

Contemplated a rollback of W10 to version 1709 [was past the time limit so couldn’t]

Considered a system restore [but W10 upgrade I think reset all my restore points]

Unistalled SU and clean booted and reinstalled NOTHING

Gave up and resorted to the wise minds here

and as typing this decided a couple of tests

hmmm I can draw a rectangle if I type in the distances

went to preferences , went to Drawings / Clickstyle

somehow my usual preference had changed from Click-Move-Click to Click-Drag-Release

Now either either someone in the office is playing with my head or I am getting old [I am] or

Windows 10 Update was the cuplrit

2 hours wasted - the moral of the story … I wish I knew :slight_smile:


#2

Microsoft should be charged for all the hours people spend due to automatic updates breaking things. I wonder if there would be any revenue left.


#3

Recently, I updated my Mac and had a similar problem were applications became uselessly slow. If I remember correctly, the update was about 5 GB. I deleted about 50 GB of files from my computer (I had copies on an external drive), reinstalled SketchUp, and that solved the problem. In fact, my computer is running faster than before the update now. :smiley:


#4

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.