SketchUp Mozaik Plugin issue


We are a small business in the cabinet making industry and we use a software called Mozaik to design our cabinets. That software has a SketchUp Plugin (using Sketchup 8) to render our job so we can present it to our customers.

This weekend we migrated all of our files from OneDrive to Google Workspace Drive. The desktop version is installed on all of our computer in order to reach our job files from the different softwares.

However, everytime we try to open a job into sketchup, we get the message saying: cannot find material name G:drive…(drive location)…False False (see attached image)

Is there a way to fix this issue?

Thank you,

You should contact the author of the extension. They should be able to give you a solution.

Please correct your forum profile. It says you are using the free web version of SketchUp 8 which is not possible.

The SketchUp 8 option was not available in the dropdown menu.

The other software has not been able to help us. I was hoping the sketchup community may have additional advice.

You have SketchUp 8 already. But you would be using the Free/Make or Pro version not the web version.

Maybe there is someone here who uses Mozaik who can help you. You might consider editing the title of your thread to make it obvious you are looking for help with Mozaik.

It looks like the plugin uses a file path (with some special characters replaced by underscores) as material name. If there is no material in the Materials browser with this name, then it is an invalid name (and invalid file path as well).

It could be an issue in the plugin, or in the job files.

  • Are you sure you are using the plugin correctly, the same way as before?
  • Does it still work with old job files (from before the migration, and with needed .jpg images added back to the original location)?
  • Are the job files plain text files and can you open them in a text editor to check that they contain valid file paths (no underscores) and that they contain valid material names (not using file paths where there should be a material name)?

Hi, thank you for the help.

We were able to find the issue by comparing with the workstation of one of our coworker not having this issue. The character “é” from the file location was causing it to bug as it is a special character. We have had to change our computers language settings from french to english to resolve.

Many thanks for the insights.

Note that Unicode path support on Windows did not arrive until SketchUp began shipping with Ruby 2.x, which was v2014 and later.