SketchUp model not refreshed in Viewer


#1

I am editing on a model using SketchUp Free. The model is stored in Trimble Connect. I can see the model in SketchUp Viewer for iOS.

If I make changes to my model, save to Trimble Connect, sync with the Trimble Connect cloud, then I can see the changes when connect to SketchUp Free from another computer but the changes do not propagate to the model in SketchUp Viewer for iOS.

I have tried deleting the model in SketchUp Viewer; logging out of Trimble Connect and logging in again, but the issue is still there: I get a different model than I see in SketchUp Free.

Can anyone help, please?

Thanks!


#2

Try clearing the cache on your iPhone/iPad, it’s not so common on iOS as other operating systems but it can get clogged up now and again. Also make sure the app is completely closed and reopened.


#3

Thanks. How do I clear the cache?

I tried completely closing the app. After deleting the local model an re-opening it even re-loads from the cloud but I still get an out-of-date model.


#4

I don’t have any iOS devices myself so I can’t say for sure, but you can see a guide here that is probably accurate: https://www.macworld.co.uk/how-to/iphone/clear-cache-iphone-3609079/


#5

Thanks - it seems a long shot that this should be a Safari cache issue.

Has anyone seen the behavior that I am asking for working (or not working) on an iOS device?

…Allan


#6

Yes I have, with most of the apps I have made since 2010 for iOS. Did you read the instructions, step two is clearing the cache for apps not Safari, did that not work for you?

I used to work in iOS QA for many years, I feel your pain, one of the reasons I moved to Android!

Well I think if the cache did not work then identify the steps:

  1. SketcUp Free
    -Can you open the model in SketchUp Free?
    -Can you open the model in another browser in SketchUp Free?
    -Can you open the model on another machine in SketchUp Free?

  2. Trimble Cloud
    -Has the file updated (check time stamp)?
    -Can you share the updated model between other browsers and computers?

  3. Local iOS app
    -Is iOS up to date?
    -Is the viewer app up to date?
    -Have you deleted and re-installed the viewer app (using direct download not cloud backup)?
    -Have you cleared the cache?

Since everything seems to be working in the first two areas it would look like it’s an app issue. I would check those points and then go from there.


#7

Hi liamk887

I have not tried clearing the Safari cache (step one in the macworld.co.uk article) since Safari is not involved at all.

Now,

  1. SketcUp Free

-Can you open the model in SketchUp Free?
YES

-Can you open the model in another browser in SketchUp Free?

-Can you open the model on another machine in SketchUp Free?
YES

  1. Trimble Cloud

-Has the file updated (check time stamp)?
YES

-Can you share the updated model between other browsers and computers?
YES (per the answer above)

  1. Local iOS app

-Is iOS up to date?
YES (not the version that came today(

-Is the viewer app up to date?
YES

-Have you deleted and re-installed the viewer app (using direct download not cloud backup)?
YES

-Have you cleared the cache?
NO, not the Safari cache.

So, even if I delete SketchUp Viewer from my iPhone and re-install, I get an old version of the model. Strange.


#8

Sorry I think you mis-read, I was saying empty the iOS cache not the Safari one, hmm not sure then if it’s still not working.

Very odd it’s working in the browser client and Trimble Connect, have you tried on another iOS device? Could you share the model with us to check?


#9

Thanks. I might have seen problems switching between computers anyway, in which case this issue is not related to SketchUp Viewer anyway.

This is a spare time project for me - I’ll get back when I can consistently reproduce the problem.


#10

Same problem here. Cannot display the latest version of my model after doing updates.

As a work around I saved my model to a new location and then opened that newly saved file. hey presto there it was in all its 380k glory.

Hello Sketchup Viewer App support:

Using iOs 10.3.3 on ipad air, and app version 2.3.2. trimble connect cloud service. In the app there is a demonstration model dance studio which displays correctly, my re-saved and re-opened model shows correctly.

  1. Caching of previously encountered files. Uninstalling the app and re-installing also showed me the same out-of-date version of models which I was seeing before uninstalling. iOs storage management should not allow that to happen, so maybe the stale file is cached on the server side ?

  2. S o m e t i m e s a trash can icon appears on the model information panels “Deleting a model will remove it from this device only. The file will remain on Trimble Connect for future use” It seems like this does actually delete the model file from the device as after doing this the model has to be downloaded again to try and open it. Only downloading it again only gets back the same out of date / empty model file.

  3. S o m e t i m e s that trash icon appears, usually not. The trash icon seems more likely to appear after resetting App Tooltip setting in the support menu.

iOS doesnt have a clear cache like android - the closest thing is in the setting page:
iOs / Settings / General / Storage& iCloud Usage / Manage Storage / SketchUp / Delete App
which as mentioned above does delete the app, but after re-install the same stale app data reappears.

  1. Raising a ticket with support customer_services@trimble.com only gave a canned sketchpro salesbot reply so thank you for finding this information here.

#11

I have the same issue. Any update from customer support? I’ve sent in a request (5 days ago) myself and have not heard anything as of yet.


#12

Hi,
Some news: CS replied and after some discussion they have acknowledged the issue and have said it will be fixed in an update to the app - no date given however.

The deciding factor was that the size of the model in bytes as downloaded by the app did not match the size shown on sketchup free or when browsing trimble connect. Sketchup free and Trimble connect were in agreement about the file size but when downloaded to the app the size was always much less. So you can check that to confirm if your case is the same issue.

For now I will stick with my workaround method of saving the model to a new name in sketchup to force the app to download a “new” complete file.

Hope that helps.


#13

Thanks for checking with CS. I’ll use the workaround for now, then, and hope for an fix to arrive soon.


#14

Any update on this? Still happening…


#15

I have the same problem. I have been working in a project on my laptop for about a week. Today I tried out the app and when I downloaded the file to my iOS device it had a version several days old. Therefore it is definitely not a cache issue.


#16

Still no update on this?

iOS app still does not download the updated file.


#17

I also have this problem on iOS app. Is there an eta on the fix?