SketchUp Mobile Viewer 5.0 - iOS solutions

Lots of changes and updates are being made to the SketchUp Mobile viewers. I wanted to open a topic for common issues and their fixes on iOS devices.

Models Are Blank:
This particular issue is recent AND troublesome because I still haven’t pinpointed exactly why this is happening to some users. We do not currently have a fix for this, as I am still collecting data. This item is a top priority. If this is happening to you, please share the following information:
-Device Model
-iOS Version
-SketchUp Viewer Version
-Screenshot of any errors you might be seeing

EDIT If you are using an older, 32bit device on iOS version 10.3.3 that is no longer receiving updates from Apple, there is a chance it is using an older version of OpenGL that is not compatible with SketchUp Viewer 5 (the current version). The development team is looking into adjustments in the future to allow SketchUp Viewer to run on these retired devices. The OpenGL incompatibility between iOS 10.3.3 and newer versions appears to be the cause of the Blank or White screen when viewing models.

Slow Responsiveness / Crashing While Loading Large Models:
Currently, SketchUp Mobile Viewer is built to view models up to 10mb in size. I’ve seen examples of successfully viewing models 20 or 30mb in size, but it becomes less reliable as the size increases. There are workarounds, creating scenes and turning off unneeded layers (layers that are not currently being viewed in a scene), reducing complex textures, using entourage components (chairs, foliage, vehicles) with simpler geometry. Possibly using extensions like CleanUp3, or following tips from the Agile Modeler’s Guide. If you have a technique that works for you, share it with the community!

UPDATE November 18, 2019
We may be on to the cause for the “models appear to be ghosted or grayed out” in SketchUp Viewer. It seems that whenever Apple does a major iOS update (like iOS 12 to iOS 13), where the applications are basically reinstalled, that SketchUp Viewer can lose its .skp file association to other apps that can also handle .skp files. Especially if they get installed before SketchUp Viewer. The problem is, I’m not aware of an easy way to change file associations in iOS without finding and deleting the app that is holding that file association. Any app that can view a .SKP app would be suspect and sometimes even apps like Dropbox can do that.

1 Like

Model Blank iPhone 5 ios 10.3.3 SU MV 5.01

Thank you for that insight. I know the iPhone 5 stops at 10.3.3, so we won’t be able to test for a fix with iOS 11 or 12.

Still no fix by just re-releasing previous version that DID work on iPad 4 iOS version 10.3.3

can’t understand why Trimble won’t release a software product they know is working.

Models are blank. iPhone X, IOS 12.3.1, SketchUp version 5.0.1, when I click on “Trimble Connect” the screen is white and shows no files or folders.

Thanks for your help on this!

Would you mind trying to log out and then logging back in? It may have just lost the authentication token.

I have tried logging out and then back in with no success.

Not sure if this is the bug you are referring to, but I see no models in the ipad viewer. Trimble connect just shows Europe/Asia/NorthAmerica, all of them empty (NorthAmerica has another empty folder inside). On the web with the same account, I see my models.

Device is iPad Pro 10.5, iOS12.4

1 Like