How to refresh a previously-downloaded model in Sketchup Viewer?

I have tried googling this but keep getting links on how to download the viewer!

I have downloaded one of my models from Trimble Connect - all good.

But now I have modified the model in SketchUp Web, I want to refresh or re-download my model so I can view it in SketchUp Viewer… but that model in Trimble Connect doesn’t have a download icon any more… and tapping it simply opens my old previously-downloaded model.

I see references to a trashcan icon (from back in 201) that I don’t see.

What am I missing? All help welcome.


The thumbnails of the files in the welcome screen in the free web based app might not always show the correct ‘recent files’. One might have edited it in another tab.
If you want more control of all your models, head to and sign in with the same email (it should if you use the same browser)
There, in the SketchUp project, you will find all your models.
Checking the tickbox in front of the name of the model will open the details panel on the right (select one only) and you can see the version history and download the right version (just download will use the latest)
You can open that in the Viewer app on your machine.

Hi Mike,

Thanks for your reply. I haven’t logged in here for a while so am only just seeing it now.

I was not aware of this Trimble Connect web page… thanks.

What I’m not seeing/understanding is how this interacts with the mobile app “Sketchup Viewer”?

So if you use the mobile SketchUp Viewer (I us Android) and you download one model this all works well.

But if we update the model in SketchUp (add a box, change the view then save)… then open the Sketchup Viewer app again… It does not prompt to re-download the modified model… it just re-opens the originally downloaded one.

What I’m hoping to find out is how to trigger a refresh of a model when using the mobile SketchUp Viewer app… aside from clearing app-data and relogging in again on the app.


In the start menu of the Mobile App, open the Trimble Connect folder by clicking on the icon next to the Home folder ( looks like this:)

Otherwise, it will open the first locally saved copy.

tried that, still opens local copy. looks like you have to delete from home page and redownoad a new copy. wish there was a prompt to update to a newer copy found online, would improve the ux some