Sketchup Viewer on IOS 8 crashes when I try to open a model


#1

I purchased this app to evaluate if I should buy a copy for each one of our field supervisors. I downloaded it after I updated my OS to IOS 8 so I did not try it on the previous version of the OS. I am wondering if the viewer needs to be updated to work with IOS 8, or if there is some other issue.
The model I uploaded to 3D warehouse for testing is very simple and the file size is small. It downloaded to my tablet and when I tried to open the model, the app crashed. So, I found an even more simple model from 3D warehouse, downloaded it and tried to open it. It also caused the app to crash.
I searched and did not see anyone else having this problem, so I am hoping it is something simple. Could it be possible that my iPad is not robust enough to use this app? I have a 64GB (35GB available) iPad mini with an A5 dual core chipset. It is fairly new, so I hope its not a hardware issue.


#2

Unfortunately I have the same problem. I have the latest ipad, so it’s not the hardware thing. I tried even to open sample file provided with the app, result is always the same - crash. I’m also on IOS8.


#3

Hi all,

This is a known issue and we’re working on a fix. Hang tight.

Thanks,
Chris


#4

Me too! I have the same problem. I have the iPad Air.


#5

Hi all,

Updating to iOS 8 will cause the current version of the SketchUp Mobile Viewer app to crash. If you can, hold off on updating to iOS 8 until after the fix / update is live.

  • Chris

#6

Hi all, just a quick update to let you know that an update for the SketchUp Mobile Viewer app went live on the Apple App store last week. This update fixes issues related to iOS8. Thanks for your patience and our apologies for any inconveniences that may have been caused by our not having the app update published in time for the release of iOS8.


#7

Yes I have the same problem on my IPAD air 2 and iPhone 6. Crashes every time


#8

Hi Hilary,

Thanks for reporting your issues and sorry for the trouble. Certainly not the experience we’re aiming for.

By chance have you tried uninstalling and reinstalling the app? And have you tried using the app after quitting all other apps that might be running?

If so, and if you’re still experiencing issues, it would be helpful for us if you would be willing to send the model you’re trying to open so that we can use it for testing. If it’s a larger file, please feel free to share with me (mike@sketchup.com) via Google Drive or Dropbox.


#9

Mike,
Looks like I figured out the bug. If I close all of my background apps then I can open my model.
Thanks


#10

Hi,

I have just purchased sketchup viewerto be bale to present projects to my clients. The app keeps crashing anneve succeeds in downloading any model, even the ligtest one. This is utterly frustrating. I operate an Ipad secind gen with OS 8 and have tried your suggestion of turning off background apps, but it does not help. Any suggestions?


#11

Hi Mike,

And my apologies for the typos in the above post… courtesy of Ipad!
How can I get the viewer to perform? You cite a patch that went live a while back, but I assume that having downloaded the app just now, the issues should be resolved. Can you please help?


#12

Hi Elianart,

Have you also tried uninstalling and reinstalling the app?

If yes, the best thing to do next might be to forward the file you’re trying to open so that we can look into what might be causing the issue.

We fixed some previously known issues, but you may be experiencing a new issue.


#13

Hi team,

I purchased this app over the weekend and have the same issue… iPad with iOS 8, plenty of memory etc. but I just cant seem to open my models, or if they do eventually open; it’s only a matter of time before the app crashes me out to the home-screen.

I even tried using the sample models and basic models less than 1mb from the store --it makes no difference.

Given there are so many people facing the same issue it sounds like a bug with the App? -does the Sketchup crew have a fix coming or what?

Very frustrating.

-Steve.


#14

Hi All

I have, and have had the same problem for some time. I was opening 10Mb files from Dropbox without issue but then for no apparent reason the app downloads the file and then just hangs - no action for 5mins +. I’ve deleted and reinstalled the app without change. I’ve also tried a file that has not been changed since it was working correctly and it still crashes.

In sequence, I open the app, tap the cloud icon, select the Dropbox icon, navigate to the file and tap. The app says that the file has not been downloaded so I OK to download (20 sec or so) and with the Dropbox icon still showing it says “loading”. At this point it ether crashes to the desktop or remains loading for ever.

One more thing I’ve noticed is that when I uninstall and reinstall the app it remembers all my login details for Dropbox - maybe not everything is deleted when it’s uninstalled??

I think most of the above happened on IOS 8 and now I’m on IOS 9 but without any noticeable difference. I’m on an iPhone 6.

Whatever the case It’s really frustrating to have it work and then not and I’d appreciate whatever advice you can give.

Justin