Sketchup Model Crashing from - Importing or Copy/Paste-in Place from other file

Hey All, we keep getting a bug splat when trying to copy-paste our building model, into our site model. I see a lot of topics about crashing from 3D warehouse, but not between two SketchUp files.

The building model component that we are trying to paste / import (have tried both ways), is 28Mb, the site model is 39Mb.

These are the thing’s I’ve tried so far (not sure exactly how the operation works in regards to style or other elements that are visible in the model, but just thought it would be worth a try):

  1. purge unused and fix problems in model info dialogue and resaving both models. (no problems found in both site and building model)
  2. turned off topo geometry and other elements in the site model before importing or pasting
  3. using simple non-rendered style when pasting
  4. taking files off dropbox and trying locally
  5. Turning off furniture and fixture layers for the copy/paste operation
  6. Save/as building model as a component, and then import into site model using file/import.

I have done this operation before using models of similar sizes, and sometimes larger and more complex. What else can I try for fixing this? This is a big part of our process so I want to make sure we come up with a way to avoid this happening on all of our projects.

Here is a snapshot of the older building model with the topo that we are trying to update.

Thanks very much!
Ciro

Can you upload a link to the two files so we can try the copy paste on a different machine? I have heard of this with larger files when the ram maxes out trying to write to the clipboard, but your files are not so big. Are both files geolocated? Try un-locating one that is being copy-pasted?