SketchUp Make Launch Error with Nvidia Titan X


#1

Hello,

I’m receiving a popup launch error when running SketchUp Make stating that the error is caused from my graphics card either not supporting hardware acceleration or OpenGL 3.0+, but I am running Quad Nvidia Titan X with the most current drivers and the specs says the card supports OpenGL 4.5, so I am puzzled.

Please help with step-by-step directions for settings if possible.

Thank you.


#2

Recent Win 10 updates are causing havoc. (Forum search)

  1. Some users report that these updates have reset some graphics settings.
    So check in the Nvidia Control Panel that SketchUp (and other graphic intensive applications) are still set to use an Nvidia GPU.

  2. Some users report needing to reinstall their graphics driver suites after these updates.


#3

Hello DanRathbun,

  1. I manually searched for the Nvidia Geforce 900 Series Titan X drivers and downloaded it.

  2. I ran Display Driver Uninstaller (DDU), and rebooted my system into Safe Mode.

  3. I selected “Clean and Restart” to remove the current Nvidia drivers from my system as well as the registry, then the system rebooted the pc.

  4. After reboot, I ran the latest Nvidia driver setup file that I had previously downloaded from the Nvidia Support website to reinstall the latest drivers back onto the system.

  5. A reboot to complete the graphics driver install was required.

  6. After the reboot I ran the SketchUp program.

  7. SketchUp program successfully launched with no errors.

Thank you for your assistance.


#4

This topic was automatically closed after 91 days. New replies are no longer allowed.