Sketchup won't launch

Getting this error when I try to launch sketchup 2017

image

I’ve checked the drivers and they are up to date. Tried changing the graphics card application to NVIDIA and doesn’t help. Have uninstalled and reinstalled sketchup as well as updated Windows. I loaded my sketchup file on another PC and it loads in a flash. On my PC it used to take over 10 minutes to load. Now it won’t even launch the program.

Is this a HW problem? Is my graphics card fried? Everything else on the PC works fine. I can watch videos no problem.

Please Help…

How did you check? Did you go to the Intel website? The latest drivers were released less than two weeks ago.

This obviously won’t work if you don’t have a Nvidia graphics card in your computer.

Intel HD 620 is a graphics system that is integrated in your main processor and uses your system memory instead of dedicated graphics memory. Traditionally, these have had all kinds of issues with OpenGL support with SketchUp, and are not recommended. With the right driver, they can probably be made to work.

I do have an NVIDIA card.

I figured it out. It was my docking station. Don’t know why it would cause Sketchup to not launch but I’ve been using this docking station for years and it used to work with Sketchup no problem.

It has been known that older DisplayLink docks (I had this problem with a Lenovo one) do not suppport OpenGL with connected external monitors. If yours worked before but stopped I would suspect that a Windows update introduced an incompatibility. You could look for a firmware upgrade from the dock manufacturer. We had all kinds of problems with our HP docks (not specifically with SketchUp) that were ameliorated by upgrading the firmware and the Thunderbolt drivers.

That very well could be the issue. I recently did a Windows update and I thought that was the trigger. But I deleted the updates and still had the problem. I’m not sure my docking station is supported any more. It’s over 5 years old now.