Unable to launch with Nvidia Quadro GPU

Hey guys,

just got a new beast here with Nvidia Quadro T2000 card and non of the Sketchup Pro is working (2007-2020). There is just an error message launching the software. Drivers up to date, everything is brand new. I uninstalled Nvidia driver and the application launched. Brand new powerful graphics card and the software is not working, what a heck! Please help.

thanks

What is in the error message?
Have you checked in the Nvidia control panel 3D application settings that SketchUp is set to use the Nvidia card?

No error, just a bug splat screen…

How to check those settings??

I’m not sure about the crash, but I am working on another case where no version will work.

To help me with my other case, can you go to this page in Chrome, and show what the Graphics Feature Status part says?:

chrome://gpu

right click on an empty space of the desktop. If no options appear, goto:


and download the latest.
Tip: when installing, be sure to have the notebook wired (battery) and run the downloaded file by right clicking on it and choose ‘Run as Administrator’

I hope you have need for the quadro with other software packages, because if it is just for SketchUp, you are better of with the geForce RTX series, more bang for the buck, so to speak…

SketchUp needs a game engine to play.

The latest were installed.

so, what happens if you right click on an empty space? Do you see the NVidia settings?
Other ways, type in ‘Control Center’ in the bottom left corner.

Once opened, be sure to set the ‘Strong Graphics Card’ to be used. DO not let Manufacturer’s bios or Windows decide for you, they will always choose the internal Graphic Card to uphold battery usage claims.

Mike, here is what it shows


Graphics Feature Status

  • Canvas: Hardware accelerated
  • Flash: Hardware accelerated
  • Flash Stage3D: Hardware accelerated
  • Flash Stage3D Baseline profile: Hardware accelerated
  • Compositing: Hardware accelerated
  • Multiple Raster Threads: Enabled
  • Out-of-process Rasterization: Hardware accelerated
  • OpenGL: Enabled
  • Hardware Protected Video Decode: Hardware accelerated
  • Rasterization: Hardware accelerated
  • Skia Renderer: Enabled
  • Video Decode: Hardware accelerated
  • Vulkan: Disabled
  • WebGL: Hardware accelerated
  • WebGL2: Hardware accelerated

Thanks, that did help my other case, he is seeing most things disabled, so I hope he has a more general problem.

I will message you to find out enough information to be able to look up the bugs plats.

Mike, sorry I noticed that setting after I made a screenshot, I applied the change as you advised, no luck.

I looked at the bugsplat, and the error seems to be Intel GPU specific. I found this discussion, where Intel try to help someone get past that problem, maybe something there will help to fix the Intel GPU side of things:

There are two or three times when SketchUp decides what GPU to use. You can get cases where the welcome screen is fine, but the document isn’t. Or the document would have been fine, but the welcome screen isn’t.

What is your monitor setup? Does the crash happen before the welcome screen appears?

Also, do you get a crash if you double click on a SKP file, and if you open SketchUp on its own?

Colin, disabling Nvidia helps, but that is not why I bought this $3k workstation. It does not open SKP as well, same error.

Guys, I feel so stupid working on this issue most of the day. Never try launching SketchUp via RDP.
Resolved.

Ah… The penny drops. That’s new information about the problem you were seeing. Glad you got it sorted.

Glad you figured out what was up. I wasn’t intending you to give up Nvidia, but to get past an Intel error so that you could then try the document window, hopefully running with Nvidia.

It is not officially supported, but it works with some RDP systems. The RDP has to support OpenGL. Some people have also had success with launching SketchUp on the regular workstation before connecting via RDP.