Can't launch Sketchup, getting graphics card error

I am a new user of SketchUp. Getting Graphic card error on new installtion

I have an F5 core i7; EVGA 04G-P4-3975-KR; RAM; 256GB SSD; 1TB M.2 SSD

When I try to load a SketchUp file I get an error that says “Tests that exercise your Intel HD graphics card’s capabilities have failed”. Sketchup won’t launch.

I’ve tried updating drivers but it says all drivers are up to date. Tried switching the application to the Nvidia card with no difference. In the past when I loaded the file it took over 8 minutes. If I use a different machine it loads in 3 seconds.

Is my graphics card fried? Nothing else seems to be affected. I watch videos and movies with no problem.

Don’t trust Windows for graphics card drivers. Go directly to the Nvidia and Intel websites and download and install the latest driver for your Nvidia graphics card and the Intel integrated graphics. Your graphics card is 9 years old but I think it should still work (if not “fried”, and if it is, you should see it in other applications too).