Sketchup Make 2017 Printing to Scale


#1

Hi. How do I print to scale.
If I draw a rectangular picture 250mm x 30mm in Make, how can I print this out to these dimensions?


#2

There is no SketchUp Make 2018. Your profile says you are using SketchUp 2017 Make. Are you? Or are you using SketchUp Free which is web based?


#3

Apologies it’s Make 2017


#4

For Sketchup Make–the desktop version–the procedure for printing to scale goes like this.

Set the Camera to Parallel Projection and select the appropriate standard view.
Resize the SketchUp window so its shape is close to the same shape as the rectangle. Drag the edges as needed for that and use Zoom Extents to keep the model as large as possible on the window.


Once you have it set up, go to Print or Print Preview and make the following settings.

Untick Fit to Page and Use Model Extents.
Set the Scale as desired. I set it for 1:1 in my example.

You can see how many sheets you’ll need near the lower left. If it’s more sheets than you think it should be, you could try resiznig the window further but keep in mind that the printer drivers will determine the printable area and you might need more sheets to get it on.


#5

Thanks Dave, will try this


#6

Dave I tried this method but unsuccessfully.
The A4 page is 297mm long, my image is 260 long.
If I scale to 150% then I can get the printed image to 220, 40mm short.
If I scale anymore it does not show the entire image in preview …it cuts off about 20%
Is there any way to set the margins manually, this may solve the problem


#7

I think you missed a step somewhere. Did you resize the SketchUp screen to fit tightly around your model? If you had, I would expect the lines to show up in the middle of the sheet as it did in my example.

What are you scaling to 150%?

Look at your printer settings in Control Panel.

If the knife pattern is too long to fit within the borders when aligned to the page. You could rotate it so it fits diagonally.


#8

Hi Dave
Please help.

How do I resize the window in Make2017

Thanks dali


#9

Printing to Scale … SketchUp Sage


#10

Drag the edges of the SketchUp window. You may need to first click the double square icon in the upper right corner between – and X.


#11

OK Dave,

  1. click the double squares to basically wrap the window around image

  2. Choose camera parallel and zoom extents

  3. click print and untick fit to page and tick use model extents

5)tick scaled, landscape and A4 paper size

Hope I have not left anything out!

Below is what my print preview looks like.


#12

No. Untick Use Model Extents.

From your screen shot it doesn’t look like you have selected Landscape. The white representing the paper shows in Portrait.

Did you actually rotate the model so it matches the landscape orientation?


#13

Hi Dave
Yes I did select landscape in the printer setup.

After 8 hrs I managed to get it right.

This is what I established

  1. Select Camera parallel and then click zoom extents

  2. Reduce page size by selecting the two squares at top right.

  3. This makes the SketchUp page about 30mm square and very difficult to work with as it’s so small.

  4. Very important to note is that if you put dimensions in, they will not reduce when you reduce the page, resulting in a confusing image. Remove dimensions before reducing

  5. Select print and setup the page as follows:

Unclick fit to page

Click landscape

Select scaled and insert your scale

Select preview

  1. I found that if I moved the image on the reduced page, with hand, by 1mm, and then selected preview, the image could move 200mm on preview

Thanks to all, esp Dave for your patience with me!

dali


#14

As I wrote several times in this thread, drag the edges of the SketchUp window (page) to make a long rectangle of the drawing space. If you had rotated the model so its length was horizontal, the SketchUp window could be the full width of your display and just reduced in height. No need to work with the window so small you can see what you’re doing on the screen.

You need to also hit Zoom Extents after you adjust the size of the window and you may find you need to do that more than once.

Glad you finally got it but it shouldn’t have taken you 8 hours to do it.