SketchUp LayOut - Technical Problem - Special Symbol

bug
layout
text

#1

Hi Community / SketchUp

There is a bug that I’ve noticed since using LayOut in 2014 right up until the newest version 2017.

When making text and using the “≤” or “≥” symbols, the block starts doing strange things after some actions (moving, etc.) The text typed in the box no longer fits at that size (little red arrow), and the spacing between lines is very large, even when I do resize it.

As soon as I remove those symbols within a text box, that box goes back to normal spacing and text fits in the original sized box again.

The temporary solution I use is to leave the symbol out and insert it (using the Alt+243/242 shortcut) just before doing the PDF export, so that the box doesn’t do its jumble. If I reopen the LayOut file, the jumble is back again though.

Is the SketchUp team aware of this and is it an unavoidable bug, or is it possible to squish that bug?

Thanks!


#2

I just tried it with those symbols in LO2017. I’m not able to duplicate it. What font are you using in your text boxes? Perhaps you could supply a sample LO file that exhibits the problem?


#3

Hi DaveR, thanks for replying.

I’ve used various fonts with the same outcome, but the most recent font is “Segoe UI”.
It does sometimes take a few actions, such as copying/ctrl move, saving and re-opening, or duplicating the page to start doing the buggy behaviour.

Perhaps it is something else I’m not aware of but I’ve tried many things, and only removing those particular symbols has fixed the issue so far.

I’ve attached a picture which compares similar text boxes with and without the problem, as well as the original LO file.

LO Sample - Text Bug.layout (214.9 KB)


#4

OK. I see the red arrow indicating the text box isn’t large enough for the text. That’s not a bug. It’s telling you the truth. It’s due to the font used for the ≤ symbol. The Cambria Math font just has a lot of padding on the top and bottom because some of the glyphs are taller than normal text.

I switched the symbol to the same font as the rest of the text and the arrow is gone.


#5

Thanks for the effort with your reply!
The Cambria Math Font is something I haven’t noticed before.

I changed it to the same font as the rest of the text, then tried to do a copy move after changing it, and it seems to reset itself back to Cambria Math, and it seems I also can’t change it again to another font after that:

After realising I’ve never noticed the Cambria Math Font…it feels like I could be missing anything. Is there something else I’m missing?

Thank you for the help!


#6

I didn’t have any problem with the font changing after I set it to match the rest of the text. When I opened your file, the font for the rest of the text was set to Verdana. I expect that is because I don’t have the font you used and so a substittution was made. Check to see if the font you are using contains the ≤ glyph. If it doesn’t that would cause the substitution.


#7

It does seem to have the glyph in the character map for that font:

It also shows up in Verdana with me, but changing to Verdana has the same effect where it changes back to Cambria Math.

It does change to the font I choose, after erasing and retyping the glyph.


#8

So to anyone that might see this it seems the issue is related to the symbols resetting themselves to the Cambria Math font after copy moving, copy paste, duplicating page, or after saving and reopening the LayOut file.I haven’t seen it reset itself to Cambria Math with any other particular actions.

There’s a chance it may be some OS setting or something else, considering DaveR doesn’t get the glyphs (“≤”,“≥”) resetting themselves to Cambria Math after changing them to another font.