Sketchup Layout Keeps Crashing at Startup (When clicking on UI)

crash
bug
2016
layout
su2016

#1

Hey there misters and misses!
I checked to make sure this specific issue wasn’t the same as others, but if I missed a topic that has my solution, I do apologize.

I am having an issue where whenever I open up Sketchup Layout (2016) and click anywhere on the Layout screen, it immediately bugs plats. My Bug Splat number is #4990 if that helps at all. I have tried a multitude of solutions, but haven’t yet tried reinstalling Sketchup or Layout yet–I’d like to use that as a last resort.
Any suggestions?

I have been using Sketchup for 4 years now, and never have I come across this issue.
We have a deadline to meet here VERY soon and so this came up at a very inconvenient time (if there’s such a thing as convenient).

Just a quick rundown on my specs:
iMac OS X Yosemite
NVIDIA GeForce GT 755M 1024 MB
16Gig of RAM

Thanks for any help y’all can give me! I’m excited to get this resolved.
Scott


#2

Do you have all the Yosemite updates installed from Apple ?

Have you got SketchUp 2016 updated to the latest maintenance release ? (v2016M2)

Have you tried v2017M1 yet ?


#3

Hold down shift when you click on LayOut (open without opening any previous documents) - it’s crashing on GetContextSpecificMaxGLTextureSize in a model you’ve put in this document. Once it opens, check the model in SketchUp and update it.


#4

Shift or ctrl? Shift just selects it and doesn’t really do anything.

And yep! Everything has been updated, but I’m not yet on Sketchup 2017 yet. Would that help at all?


#5

specifically the line “To temporarily prevent an app from re-opening its documents and windows, hold the Shift key while you open the app.”


#6

Nope. Didn’t work at all. Any other suggestions?
Sorry for the late response, was at Drill.
Hope everyone had a good weekend.


#7

Shift has to work: you’re not opening any documents. Are you SURE you’re not trying to open an existing document? You have to be… betcha a donut. The only way it couldn’t is if you have a default template that has a corrupt model in it.


#8

I opened it up on my windows computer and it works fine. No issues whatsoever.
It’s only on my Mac. Shift isn’t the problem.


#9

I asked if you could open the App without any documents and not crash. The call stack says you have a doc open or are trying to render a texture from a model. That’s not what I was asking for, and you said it crashed.

If it opens on Windows, try opening the model you have in the LayOut document in SketchUp, and see how SketchUp handles it. If it doesn’t crash, send that model to a new LayOut document and see if it works.


#10

Alright. Sorry if there’s confusion, and I am not intending on being difficult to work with. Again, I definitely appreciate the assistance.
I ensured I had nothing else running for the sake of following instructions to the letter, however, it did not solve the issue.

I will try that and see how that works. It runs great on my PC, but I haven’t yet sent over a copy of the original sketch that the Layout Document is using, so as far as my computer knows, it’s only an image of an inexistent sketch file.
Again, I definitely appreciate the assistance!


#11

But if there’s a GL call, that means there’s a model in there somewhere… if it was an image, I don’t think it’d require a GL (OpenGL) call for 2 dimensional things. I sent you a PM… we’ll take this offline until we find a solution.