Sketchup / layout image downsampling


#1

Does anyone have any understanding of how (or to what criteria) SU (or Layout) downsample imported images? I know they do but Im just trying to understand if I can use SU / Layout to prepare some large format UAV survey orthomosaics and do all the boiler plate borders, scalebars, drawing info etc in Layout.

They are large images around 1-2 Gb as tif’s and are to be printed and laminated A0 size (and may be bigger) and obviously the print quality needs to be spot-on, hence the question in regards to downsampling (directly influencing output quality)
I want offer the client sub-sections of the overall ortho in various scales (hence wanting to do it in SU /LO), otherwise its doing it all in photoshop / illustrator and getting my calculator out :0(


Resolution with Images
#2

Are you sure it prints and exports textures/images with reduced resolution?

Since graphic cards have limits for the maximum texture size (and prefer square power of 2images), they receive a downsampled version of the texture for display, but SketchUp does not actually downsample the original imported image (for example in the material entity).

If it is also a problem for export/print, you could split the images into a raster of tiles and import them as individual images. Tiling large data has also the advantage that the display engine only needs to load the currently visible parts and can adjust the resolution depending on the viewport and zoom level.


#3

ok, that sounds logical, i hadn’t considered it may just be GPU display interpolation - useful information. unfortunately I don’t have a way of testing the printed output until I send it to the printers.
I guess the PDF export set to best jpg quality should be lossless-ish. Thanks


#4

You can actually test it. Export the PDF and then print the PDF on your own printer. If you use Adobe Reader you can print just the center of the page and get an idea of how it will look at least as far as what your own printer can manage. Or you could print the whole thing using the Poster option.

When you export the PDF, make sure you select the High Output resolution, too.


#5

if only I had some ink! :thinking:


#6

Maybe you need to get yourself a monk! :smiley:
2608888


#7

When you import an image into SketchUp model space, it gets downsampled to 1024 pixels wide or high, or, if you have set the “Use maximum image size” in Preferences>OpenGL, up to 4096 pixels depending on your graphics card.

Images brought in as PhotoMatch scene backgrounds are not downsampled.

LayOut output resolution depends on your output quality setting. If I remember right, Low is 72 DPI, Medium is 150 (or 96) DPI and High is 300 DPI.


#8

thanks - ok, so I might be better off doing it all in layout? - I could set up a scaled drawing with a 1m box in it, then scale my ortho image to match my 1m (to scale) box.


#9

It could be of interest that with (my) new extension Large Image Splitter one can split high-resolution images into smaller tiles that render sharply.
If for example an image of >10000px width is too big to be handled easily, displays blurry or impacts performance, the contained image file would be split into 10×10 image files of 1024px and the problems may be resolved.


#10

Very cool tool, Aerilius! I could have used it the other day on a project I’m doing.

Thank you!

Before:

After:


#11

Super Duper, that is awesome.
Thanks


#12

Cool! Kind of like the Slice Tool in Photoshop.


#13

Hi Aerilius
I get this when trying to use the splitter… any ideas?

undefined method definition' for #<Sketchup::Image:0x007fc906f8eef0> /Users/rob/Library/Application Support/SketchUp 2018/SketchUp/Plugins/ae_large_image_splitter/core.rb:29:insplit_image’
/Users/rob/Library/Application Support/SketchUp 2018/SketchUp/Plugins/ae_large_image_splitter/core.rb:398:in block (2 levels) in create_command' /Users/rob/Library/Application Support/SketchUp 2018/SketchUp/Plugins/ae_large_image_splitter/core.rb:397:ineach’
/Users/rob/Library/Application Support/SketchUp 2018/SketchUp/Plugins/ae_large_image_splitter/core.rb:397:in block in create_command' SketchUp:1:incall’


#14

undefined method definition for #<Sketchup::Image:0x007fc906f8eef0> means that in your SketchUp, image entities do not respond to the method definition (but an image always has a definition like a component instance). Looking up in the documentation I see that this method is not part of the API. Sorry for overseeing that.

I suspect it is added by dynamic components.

  • You can try to install/enable the dynamic components extension (was it disabled)?
  • I will have to see how to work-around and not use the apparently inofficial method definition, because the extension should not require other extensions like dynamic components.

#15

yes it was enabled / installed. I’ve tried it both ways but no joy.
thanks anyway


#16

Thanks, I found what added it and fixed the extension. Version 1.0.2 should be soon is now published in EWH after review is done.


#17

:+1::grinning:

fab. this extension will be a daily driver for me.


#18

Edit: I’m getting a slightly different message. Any Ideas?

undefined method image_rep' for #<Sketchup::Texture:0x0001ba01ff6d30> C:/Users/Gabe/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/ae_large_image_splitter/core.rb:133:increate_submaterials’
C:/Users/Gabe/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/ae_large_image_splitter/core.rb:34:in split_image' C:/Users/Gabe/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/ae_large_image_splitter/core.rb:408:inblock (2 levels) in create_command’
C:/Users/Gabe/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/ae_large_image_splitter/core.rb:407:in each' C:/Users/Gabe/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/ae_large_image_splitter/core.rb:407:inblock in create_command’
SketchUp:1:in `call’


#19

ImageRep is a cool new feature with which one can edit images. Unfortunately it is not available in earlier versions (because of this you see “undefined”).

As far as I know, Extension Warehouse should not have proposed to install this extension from within an incompatible SketchUp version. Or did you download it manually and just tried it?


#20

I downloaded manually and just tried it. I should have checked compatibility first. The energy modeling software that I use is not compatible with SU 2018 so I primarily work in 2017.

Maybe ill try to split the image in SU 2018 and then copy it over to 2017 and see if that helps Or maybe just draw the geometry in 2018 and then transfer everything over.