Sketchup keeps not responding when I try to select elements

My sketchup was working fine when I used it last week. Now, suddenly, it says not responding whenever I click to select an element. I tried updating my graphics drivers, reinstalling sketchup, but nothing is helping. I’m pretty desperate because I need it for this project. Any advice?

How about sharing the .skp file so we can see what you are working with?

I can share the file, but it is doing it on all my files, even ones which were working fine previously.

That does imply an issue with your computer then.

When you installed/reinstalled Sketchup did you do it correctly? That requires right clicking on the downloaded installer and choosing Run as administrator. Make sure you also have the latest installer from sketchup.com/download/all

What exaactly did you do to update your graphics drivers? Did you just ask Windows if the drivers are up to date? If so, go to the GPU manufacturer’s site, download, and install their latest drivers.

It might still be helpful to see your .skp file to see if there’s something in your modeling process that could be affecting this.

actually, it is not doing it on blank new files. weird

It says the file is too big to upload. Also, this issue started when I downloaded and opened this file so perhaps it is the culprit.

Upload the file to Drop Box and share the link.

I’m not having any difficulty selecting anything in your model which makes me think it is something to do with your computer, graphics drivers, or possibly an extension you have that I don’t. Idid do a couple of cleanup things on your model. First I repaired some incorrect tag usage.
Screenshot - 10_3_2021 , 1_05_10 PM

And then I purged unsed stuff from the file which reduced the file size by almost 42%.
Screenshot - 10_3_2021 , 1_05_28 PM
Have a look at this one and see if it behaves any better for you.
Georgetown Site Model purged.skp (15.8 MB)

No, it keeps crashing. I think im going to try redownloading again. So I should run sketchup as admin and then uninstall? Just a bit confused ab how the administrator part factors in

No. You should run the downloaded installer by right clicking on it and choosing Run as administrator. You shouldn’t open SketchUp as administrator.

Using Run as administrator when installing SketchUp allows the installer the premission required to install files that you don’t grant it if you just run in the typical double-click way.

Starting again:

Make sure you have the latest installer file from sketchup.com/download/all
With SketchUp closed, right click on the installer and choose Run as administrator.
If you are presented with options like Uninstall, choose Repair.
After you do that, do a cold reboot of your computer.
Also make sure you have the GPU manufacturer’s latest drivers installed. Don’t trust Windows to tell you if they are the latest ones.

There are three materials in your model that use very large (3168X4244 = 12Mpixel) images. I wonder if perhaps these are overwhelming the memory of your graphics adapter? They are named “DSC03211”, “DSC03215”, and “DSC03216”. I think they are the graphics on the sides of the sidewalk kiosks. You might try temporarily changing them to a simpler material and see if that helps with performance.

1 Like

Good catch. I didn’t check the sizes of the materials. Those would definitely be overkill, though.

I cropped and resized those images a bit. Now the file size is about 80% smaller than your original file
Georgetown Site Model purged.skp (5.5 MB)

Unless the focus of this entire model is that parking box, I think your images are really wasted here. They don’t fit the model that well and can’t be seen unless you zoom in very closely on it.

1 Like

Good catch. I actually didnt make this model, someone in my class did, so I wasnt aware of these. I reinstalled sketchup several times and no luck, even with the purged documents. Thanks for all your help, though! :confused: