Not Responding in workspace

Using older version project. Can’t edit due to locking up and getting “Not Responding”

Share the .skp file so we can see what you’re working with. Might be possible to get it cleaned up so you can work with it.

Thanks, i downloaded a few other files just to see if it was the same. It locks up every time i click to edit.

Without more to go by it’s pretty much impossible to tell you what is wrong. Chances are that your graphics card isn’t up to the task but sharing your model file will help us to determine that.

Go to the Intel website to download and install the latest driver to your graphics. It’s an integrated system so probably you should also open the SketchUp Preferences>OpenGL dialog and turn off Fast Feedback. SketchUp needs to be restarted after the change.

Yes, I understand. Here is the link for the share.

Does this one behavior better for you? I edited the style to remove Profiles which will help reduce the load on your graphics card. It’s also got the face style set to Monochrome so your graphics card won’t have to deal with textures.
plants plant.skp (2.8 MB)

A couple of other points. I fixed the incorrect tag usage. All edges and faces should be created and remain untagged.
Screenshot - 7_5_2022 , 7_10_20 AM

There are some exposed reversed faces which you should correct. You should have no visible blue back faces.

Thanks so much. As you can see, I am still getting used to working in Sketchup. I was using Autocad for some time.

Does the file I shared work better for you?

From the benchmark reports I found on the graphics card you list in your profile, it’s performance is rather dismal for 3D image handling. I think it’s time to be looking for a different computer with a suitable graphics card.