Sketchup is broken, please help!

I’ve recently posted a Topic about broken exports, People tried to help me and I did what they said. I tried using other programs like blender to fix the bugged models. Somehow the models were broken for other software and I couldn’t import it anywhere. Since then I tried to fix this by myself but I failed, I completely removed and reinstalled Sketchup, I did lots of googling and got no results for my problem. I tried 3rd party software for exporting and the models didn’t export as they were projected in sketchup. The textures assigned in sketchup were different when exported, The model is different and bugged and many different programs can’t import these files (they could before this problem started). The main problem here is that I can’t properly export it, even with native export. I just want to find out what the problem is, why all sudden sketchup is broken, because I didn’t change or download anything… I need it to work properly when exporting again like before, if anyone could help me out here, I would be very happy!

Please upload the model so the issues can be figured out without guessing.

I understand, but the problem is not the model/project. it’s sketchup itself, It doesn’t matter if I start a new project and create a simple box or plane, If I download something from the warehouse in a empty project or If I use my own project. everytime I export something, the export itself is broken and the textures are assigned differently.

Even in 3rd party exporting plugins for sketchup

What is the receiving application? Has there been an update to that? What export format are you using? What kind of settings are you using?
The 3D model export from SketchUp has remained the same for some releases already so something else in your setup must have been changed.

The receiving application is maya 2016, and it didn’t have any updates or changes. I’m using FBX (settings: 2 sided face on, the rest off) but I tried OBJ as well and other formats, but they all seem to fail to export correctly. If I tick triangulate, it seems to fix the weird overlapping vertices, but I still can’t import it into maya, it says: Unrecognized File Type either way. Before I import them into maya, I can check them on my desk with Windows 3D viewer, and unlike before (when it all behaved normally) faces aren’t connected properly right now and textures are messed up as well.

When is the most recent time you remember that the export from SketchUp and import into Maya behaved as you expected? What might have changed between then and now? Changes in software, in your export/import procedures, in your modeling approach, anything?

Do you still have a SketchUp model that worked properly before? If so, what happens when you try the export/import procedure with that model (or a copy of it)?

2 Likes

Read the entire thread:

For now you will need to clean the FBX files. OBJ are ok.

1 Like

This might be one possible culprit. What this does is to replace every SketchUp face with two faces facing in opposite directions with a very tiny gap in between. It is better to construct your models in a way that puts the backsides of faces facing to the interior of models.

The most recent time it behaved well was at the beginning of this month. I haven’t downloaded anything for sketchup, no plugins or etc in the meantime. It suddenly failed to export models clean and not messed up. I didn’t change any settings either. My modelling approach didn’t change and even old projects that exported fine before are now messed up as well, even new projects with only a box are messed up. so I can’t literally export anything clean anymore. It suddenly behaved like this.

Thanks for the link, I will read it, but I tried OBJ as well and it was also messed up.

The weird thing is, I used this all the time for my exports, but now it is messed up. I tried turning it off tho, but no succes, still messed up exports.

Test.skp (163.9 KB)

Could anyone test by exporting this sketchup file here to fbx or obj and look if 2 different textures are assigned on both side like in the project. If I export it only 1 texture is assigned on both sides weirdly enough.

For me, the OBJ file works normally, Blender imports it well, with material and 8 vertices and 6 faces.

I tried messing around with OBJ and I managed to import it into maya, but now the problem is still that the textures aren’t assigned properly as in the project.

Blender imported the OBJ file correctly, including the two materials, but only one of them is applied to both sides.

To have both materials applied to a face each, you need to edit one of them and add a few nodes (Mix Shader, Geometry)

mat-05

SketchUp is one of very few 3D applications that support applying textures to the back side of faces. Most apps show backfaces as invisible, black or an uniform colour.

1 Like

Thanks, but why does this happen?

Thanks man, after some messing around I was able to import a correct model in OBJ format into maya :smiley: I had to reassign and rename some textures but now they work!!

1 Like

One other thing to be aware of is many times SketchUp will export with custom split normals, which frequently cause smoothing and rendering artifacts.

In Blender it’s always wise to use the “Clear custom split normals” button after importing.

1 Like