Sketchup triangulates all faces on export

I am trying to export a Sketchup model to Maya. But no matter what i do it keeps triangulating all the faces. I tried exporting with and without checking triangulate all faces but to no avail. At first I thought maybe Maya was importing the model wrong. But then I opened it in windows 3D Viewer to check and it was also showing all triangulated faces. I also tried searching in forums, and Youtube videos, and articles but couldn’t find any working solutions.

if anyone can help me up with this, or export a proper format for Maya ,I’d really appreciate it. (cuz I’m pulling my hair out of my head trying to figure it out.)

I’ve included a google drive link incase anyone wants to try themselves and fix it.

K Room - Project file on Google Drive.

What format are you exporting from SketchUp?

I prefer FBX, but I also tried Collada (.dae) and obj. and got the same result.
I also tried using a plugin called Simlab - Export FBX (because it can embed the texture into the fbx file).
But yet again noting helped.

This simlab exporter?

https://www.simlab-soft.com/3d-plugins/sketchup-to-Maya-main.aspx?locale=en

OMG, I didn’t know this existed, Imma Try it.

but I used this one.
https://www.simlab-soft.com/3d-plugins/FBX_Exporter_For_Sketchup-main.aspx?locale=en

I expect the Maya exporter will do the job but why weren’t you using the native FBX exporter? It has an option to triangulate or not triangulate faces. Might be that the SimLab FBX exporter does too.

Screenshot - 5_9_2021 , 8_37_22 AM

This was the first one I tried. I exported the model without checking the box “Triangulate all faces”, but that didn’t do, so I thought maybe, just maybe for the hell of it. I checked the “triangulate all faces” box. and nothing changed. that’s when I went looking for other options and used the Simlab FBX Exporter to no avail.

I would have thought native export should work too. So maybe it’s on the maya side? Hence the Maya .skp importer.

Maybe purge the SketchUp file as well, it lowered the file size from 250mb to 67mb.

I just tried using the Simlab skp Importer for maya. and it still messed up the file.

Is there an import setting to fix that? There are a number of file types that by default require triangles. That may be the case here, too.

These are the Import setting in Maya, and not seem to be about triangulation. I tried exporting files in OBJ,FBX,DAE formats. all behaving the same way.
The way I see it the problem is not maya but sketchup, cuz I opened the exported files in Windows 3D Viewer, and it also showed the triangulated faces.

Are the faces triangulated in SketchUp? If not, I’d say the triangulation is being created by the exporter not by SketchUp.

If you take a look at the start of this topic you’ll see that in sketchup the model is not triangulated. and I’ve tried the native sketchup export system, as well as simlab’s plugins. they both give me triangulated faces as a result.

go back to the Model. I see the Tri’s where you’ve not modeled in Quads.

Eg the window. connect the corners to the corners of the walls to make quads… and no Tri’s will form… otherwise the exporter will Tri those areas to enable a hole in the mesh to be exported…

Most formats don’t like holes in the surface. learnt this the hard way modeling for export to things like Poser or anything by OBJ format.

Could you elaborate it for me? I’d appreciate it.

Yes. The walls anyway don’t seem to be triangulated in the SketchUp model. The triangulation is occurring in the exporter.

Take Khai’s advice.

It wouldn’t hurt to clean up your model, too.

With Hidden Geometry exposed. A bunch of garbage geometry.


Incorrect tag usage:
Screenshot - 5_9_2021 , 9_47_40 AM
And lots of unused stuff:
Screenshot - 5_9_2021 , 9_48_12 AM
That reduced the file size by about 60%.

There are also plenty of reversed faces that need fixing as well.

hope this explains clearly…

1 Like

OH MY GOD YES. I just tried what you said Khai, on a test model and yes it imported like a charm. thank you so so much. you’re a saint.

And thank you DaveR. I didn’t understand why the file was so big. I’ll what you said and clean it up.

Thank you so “d a m n” much, both of you DaveR and Khai, I had been stuck at this stage for about 4 days.

1 Like