SketchUp insists my keyboard has QWERTZ layout


#1

I just started working in SketchUp Make (have been using older versions of SketchUp before, half a year ago), and everything worked okay until the first mistake. Ctrl+Z didn’t work. I checked the keyboard shortcuts, tried adding ctrl+Z and it appeared as “ctrl+Y”, conflicting with Redo. I tried naming the shortcut to “undoz” and it appeared as “undoy”. Simply put, the two keys are switched.

It happens only in SketchUp - other software works fine; as I type this in Firefox now, Z is Z and Y is Y. I never used QWERTZ keyboard on this computer, never used any settings that might suggest that.

The system is Windows 7 Pro, and I’m using the Polish(Programmers) layout, which is same as US standard QWERTY, except with national characters under right alt, e.g. ralt+a = ą. SketchUp Make version 15.3.331 64-bit.

So what the heck?


#2

Just a guess, check your keyboard input language.
I’ve had similar problems with a chinese input, an ! from an US keyboard was not the same as a ! when input in chinese (for a password). Even though they appear the same, the input is technically different. So maybe the Polish ‘Z’ or ‘Ctrl’ is different from USA.

Although it would be weird that this is the only issue, if this was the problem.


#3

Then it would fail in other software. I have maybe a hundred other programs, and they all work correctly.

OTOH quitting SketchUp and starting it again helped. Some setup problem?