Shortcut do not work in the new Version 17.2.2555 64 bit


#1

Shortcut “Ctrl+z” do not work as it did in the earlier ver. Tryed to put it in manually but no result… I have a Swedish (translated) ver. so I thought it could be some language issue?


#2

Missing shortcuts can be indicative of an incorrect installation of SketchUp.
It must be done as follows…
Find the SketchUp 2017 installer exe file’s icon [probably ion your Downloads folder ?]
Select it and right-click > context-menu > Run as administrator…
Installing it any other way can have weird results - like your missing built-in shortcuts.

You probably don’t need to uninstall and reinstall - instead close SketchUp and run the installer as explained above.
When prompted choose to ‘Repair’…

When SketchUp restarts many issues are usually fixed…


#3

Thanks for the rapid answer! But…no it did no change. It looks like there is doublett in the list of shortcuts; two lines that are the same (undo) instead of one “undo” and one “redo”…


#4

I maybe have to install the english version again?


#5

Uninstall and reinstall.
See if that helps…


#6

Before reinstalling, you could try the Reset All-button on the Window menu>Preferences>Shortcuts dialog (I don’t know what these are in Swedish…)

Anssi


#7

And make sure the model viewport has focus (by clicking once in empty whitespace) before using shortcuts.


#8

It did not help to uninstall and reinstall this version. There is definitely a bug in this Swedish version.The previus version worked well!


#9

It works on mine @ NO PROBLEM


#10

@jan.thoren did you click first in the SU workspace after opening SU to ensure SU has focus as Dan suggested above? We know about the focus bug.


#11

I tried several times without success. Still think there is a bug in my “Swedish version”


#12

No success!


#13

OK, good for You. Maybe You don´t use the Swedish version?


#14

Yes I have tried “everything” now without success…
The program works absolutely fine except for the shortcut “Ctrl+z” wich is gone somewere else…


#15

Hi again,
just want to tell You that I have installed “the old” Sketch Up Make Version 17.1.174 64 bit (eng). Now everything works just the way I want.
The “undo shortcut Ctrl+z” is back!!!
I gonna keep an eye for new versions in the future, and maybe some day there is a new one that works with both Swedish and shortcuts;-))


#16

why don’t you try with "Alt + Backspace " also you can assign a new shortcut key for Ctrl + Z to see if it works.


#17

I have already tried all those manual opportunities without result. I´m quite sure that there is a bug in the version I download.
Today I download it a second time, and saw that the file size was not the same as it was the first time I download it…Aha, I thought, now is the bug fixed, but no… It was the same problem; "No shortcut “Ctrl+z”…
Anyway, the previus version works allright!


#18

I have the same problem and it’s really annoying. Is there some fix for it?


#19

Uninstall the Swedish translation and install the real SketchUp version instead. The Swedish so called translation has the terms Undo and Redo mixed up which can break shortcuts.