Sketchup 2016 CTRL+Z (undo) not working

Recently installed Sketchup Pro 2016 at work (Swedish version) and the CTRL+Z command is not working. I constantly have to click on Edit > Undo.

In the Edit panel there’s both ‘Undo’ and ‘Undo recent’, where the ‘Undo recent’ does not have a keyboard shortcut written next to it. The ‘Undo’ command do have the keyboard shortcut CTRL+Z written next to it, but it doesn’t work, and it is “unclickable” (light grey) all the time.

I have tried to update the Shortcut setup under Window > Preferences without any success.

Is this a bug or is Sketchup just ignoring the fact that Undo is an extremely common command?

Ctrl+Z works fine on the English version. Perhaps we need to find someone else with the Swedish version to test it. Maybe @eneroth3?

1 Like

I use ctrl+z all the time with Swedish keyboard, en-US as OS language and en-US Sketchup and have never had any problems with it.

Does a Swedish version even exist? I have never heard of it. Also I don’t know of this “Undo recent” thing. In my Edit toolbar I can only see drawing tools such as pushpull, move and rotate.

1 Like

Swedish is through a Swedish reseller. I do have a Swedish version, and the shortcut works for me in Swedish on a Mac with a US keyboard or a Swedish keyboard setting. Does the Z show up in the menu?

What is this “Undo recent” thing called in Swedish? I still don’t know what feature that is.

Sorry, my bad, the UNDO is the command that is missing its keyboard shortcut and the UNDO recent was something I made up.

Ångra (last command) - without any keyboard shortcut written next to it

and there’s
Ångra - with the keyboard shortcut Ctrl+Y written next to it


That translation is wrong! The second “Ångra” should be “Gör om” (or something similar, I haven’t used any software in Swedish for years and years so I could remember that term wrongly). This is why I shun translated software. It is never done correctly, at least not to such a exotic language as Swedish with just 10 millions speakers or so. Also “Grupp” should be “Gruppera”. In this context it’s a verb, not a noun.

Översättningar som denna är en styggelse!

To get back to the question: I don’t know if the shortcuts in SU are string based. Since you can add custom shortcuts for menu items added by plugins it would make sense if the shortcut refereed to the the string name of the item and not some underlying object ID. In that case having two menu items with the same name might prevent the shortcut from working. It could also be that the translators removed one shortcut because they couldn’t understand why there were two with the same name.

What happens if you go to Window > Preferences > Shortcuts and manually add a ctrl+z shortcut to “Ångra”?

“Klipp” should also be “Klipp ut” and Backspace is called “Backsteg” in Swedish. “Radera” is Swedish for Delete which is another key.

Seriously, if Trimble allow third party translations I really think they should somehow check the quality. It hurts to see this being done to poor Sketchup!


So true @eneroth3 !

This (see images) is how the Ångra command look under Preferences. There’s two commands called Redigera/Ångra (=Edit/Undo) with identical keyboard shortcuts.

And when i manually change them nothing happens, unfortunately.

Some more translation errors:
“Slå ihop ytor” should be “Skär Ytor”.
“Ritning” should be “Rita” or “Ritande”.
“Tilläggspolicy” is misspelled (särskrivet).
“Extensions” isn’t even translated, even though the term “Extensions” was translated in “Tilläggs policy”[sic].
“Allmän” should probably be “Allmänt”.
“Applikationerna” should just be “Applikationer” or maybe even “Program”.

I’m glad they didn’t translate “Cancel” to “Avboka”. I think someone who insisted on translating one of my plugins to French did something similar to that.

Is your license somehow tied to this translated version? Installing an official version should fix the shortcut error and probably also make the program easier to understand.

Also I’m a bit curios if Ctrl+Z, Ctrl+Y and Alt+Backspace all trigger undo in the Mac version for @Barry and none of them trigger redo.

I agree with you @eneroth that the easiest way to solve this problem is probably to install the official version instead. The IT-manager at the office is now dealing with that.

I hope your problems aren’t something as simple as regional and keyboard settings.
Ctrl+z on one keyboard is ctrl+y on another.
So if you have your regional settings one way but then have a keyboard set differently you may have problems.

The worst thing about regionalized applications is that a translation shuts the user out from almost all related information. I suffer from this daily when using Archicad that has been (poorly) translated into Finnish. The amount of Finnish information about problems with the app on the net is practically zero, so whenever I have to look for something I have to first figure out what the thing I am trying to accomplish is called in English.



I think we’ve already established that it’s the quality of this translation that is so low it breaks key functionality of Sketchup (no pun intended).

I don’t know who this reseller is but perhaps someone should contact them so they can have this fixed.

I have helped the swedish distributor with some of the translation, but unfortunately most of it got lost in the end…
I think some of the translation now comes from Google Translate or something.
But they will of course get feedback so they can correct things.

But to get back to the question…

Like Brad already answered, it´s got nothing to do with the Swedish translation.
Some users have experienced the same problem on the english version, including me.
Click on “Reset All” usually works.
Klicka på “Återställ allt” brukar lösa problemet.

I have looked into the problem and they have not added “Undo” [Ångra] to shortcuts.
Obviously a mistake. Not supposed to be like that.

They only have “Redo” [Gör om], even though it says Undo [Ångra], under Shortcuts [Kortkommandon] and added both ctrl+z and alt+backspace [Alt+backsteg] (both for undo/ångra) and ctrl+y (for redo/gör om).

So that´s why it does´nt work. You only trigger Redo [Gör om] when using ctrl+z or alt+backspace [Alt+backsteg]…

I think this is pretty much what I said over a week ago. The mistake however is not that the shortcut has been forgotten, but that the two commands have the same names and therefore the same shortcuts. On Windows the shortcuts trigger the latter command (Redo). Barry said something about Ctrl+Z working on Mac. If it is the same translation I would suspect the Mac version triggers the first command that matches the shortcut, not the last as the Windows version do, meaning Ctrl+Y also would trigger Undo.