Sketchup help! Can't click/edit

Hi, I’ve been working on this bunk bed model for a room mockup. It’s been functioning for several hours having no issues and then suddenly it stopped. I can’t click on anything relating to the model, cant inference on those points, but I can draw outside of the model. The toolbar works though. I’m also using Sketchup Web because I’m 15 so I cant afford the other options. I’m rather new to Sketchup and don’t have any formal training or anything like that, so I’m pretty sure it’s just something stupid I did. Is there anyway I can attach my Sketchup file? Any help is appreciated. Thanks. showbox

Your profile says you are using SketchUp Pro. Please correct that as it is confusing and will get you the wrong guidance.

I moved your topic to the SketchUp Free category, too.

It may be that you have created a huge file and are having to wait for an autosave. Did you use a lot of components from the 3D Warehouse?

Open the Components panel and click on the house icon to show the In Model components and then the Purge button at the bottom. Do the same in Materials. Then save the file and see if it behaves better for you. If you are still having problems, open the menu at the top left corner (three horizontal lines) and choose Download. Then upload the file by dragging it into a reply here.

@DaveR This is really crazy but I posted this on Reddit and my name is not SorimBela. So I guess thanks for bringing attention to this. I have no idea who this is but since this thread is already started I might as well continue with it. I will try all the things listed. Thanks. Will let you know soon.
Bed Frame (1).skp (489.6 KB)

I tried, but it didn’t work. I also forgot to mention the fact that I can write click and press invert selection and it will highlight the model but that’s pretty much the only thing I can do relating to the model. I don’t know if this helps with the diagnostic, but I figured that I might should include that detail as well.

Go to the Scene tab on the right toolbar, click the icon for Perspective, then use shift z to zoom extents and you should be able to orbit your model around the right way and use it.

@Box Ok, thanks. It worked. What did I do to make it stop working? Also any suggestion on how to make my model better.

You were using Parallel Projection, which is really for exporting images of elevations etc, when you should be using Perspective for modeling. The problem is the zoom function when in parallel doesn’t work as you would expect so your view was zoomed in so far you couldn’t actually touch your model, even tho you could see it.
So generally work in Perspective mode and only use Parallel Projection for setting up specific views.

As for making your model better, I would look into the use of components to get a better understanding of how to use them.
Components make it easy to use things multiple times without having to draw them again and allow you to edit one edit them all. So think about the parts of your model that repeat and use copies of components for them.

2 Likes

Looks like Box got you sorted out. His suggestion to use components is a good one.

As for making your model look better, one suggestion I have would be to watch for tangent when drawing arcs. The sharp transition from the horizontal run of the end frame tube to the bends comes from the arcs not being tangent. Watch for the magenta arc and the Tangent message when drawing them.
tangent

After making the first arc I double clicked in the corner for the second one so it has the same radius as the first.

Thanks